Check Engine Light on 1999 tahoe

chevrolet
tahoe

#1

I was driving to the airport. My engine started running rough, and the service engine soon light started flashing. After about a 1/2 mile, the engine stopped running rough, and the light went on solid (stopped flashing). We pulled to the side of the road, and checked the fluids. We found no problems and had no temp or oil warnings. We drove another 30 miles to the airport so we wouldn’t miss our trip. It ran smoothly the whole way, though the engine light stayed on.



My questions are multiple. Obviously, the best thing to do would be to get it checked by a service technician. I’m wondering however, based on the symptoms if we’re likely to do any more damage if we drive it the 65 miles back from the airport. Any thoughts as to what this might be?

Thanks!


#2

If you drive with the check engine light flashing then you are likely to do more damage. So don’t drive it while it is flashing.

The flashing light is most often because of a serious engine misfire. You can take the car to corporate chain auto parts stores where they will scan it for free. Write down the exact codes that you get (format: P1234) and post them.

How old are your spark plugs & wires?


#3

Which engine? How many miles? Maintenance up to date? Gas cap screwed on tight?

Check your oil, tranny fluid, and coolant levels before you drive it again. If light is not flashing, drive it to an (Autozone) auto parts store and read the codes.


#4

The engine light only flashed for about a 1/2 mile, as we were on the highway I got off as soon as possible. Will try to get to chain auto store or dealer.

Plugs and wires were all replaced about two months ago at the dealer.


#5

I have a 02 z71 with a 5.3 in it I have had the check engine light on and off for a while. I have had it checked and it comes back with a multi able miss code it is a PO300, Replaced the plugs and wires this past thurs. and did not fix so had it test again and came back with the PO300 and a PO446. Witch said to replace the purge valve so I did and nothing. I got online and started looking in to it and this is why I am posting it on here for you to read there is a list of the trucks and motors that have the issue and your tahoe is on it. If you have the 5.3, 4.8, or 6.0 V8. It is all over that it could be dirty fuel injectors or dirt or dust in the cold air return. Not sure what is on my truck I do know that I drove it up north over the weekend like 250 miles with the light on woke up sat. it was raining and light went off and has not been on the last two days. So dont know what it is or how too fix yet will try and fill you in as I go.


#6

Of course you are going to get it scanned but what I have seen for your year and your symptons, it sounds like the EGR valve, a little expensive for the part but easy to install.

For your information a check engine light has nothing to do with fluid levels, I know it sounds like it should but it does not.


#7

I got the code: P0301, but before I even got to the shop, the check engine light shut off. It appears to be running fine now. The guy I spoke with recommended adding some injector cleaner to the next tank of gas, but didn’t seem to think I needed to worry much about it.

Any thoughts?