CarTalk.com Best of Deals Car Reviews Repair Shops Cars A-Z Radio Show

Altima Crankshaft Sensor

My wife’s 2003 Altima has been stalling. The MIL came on P0335 Crankshaft Position Sensor Circuit. I did a little research and it seems that it is pretty common for that sensor to go bad, so I bought a new one. The problem is I can’t get the wires off the old one. It is in such a ridiculous place. There is no line of sight anywhere. It has to be done completely by feel. Supposedly, I should be able to push the button until it clicks and then remove the connector. When I push the button, it definitely clicks - but it doesn’t stay clicked. It clicks right back out before I can pull on the connector. How can I keep that button clicked in when I can’t see anything and I can just barely get one hand down in there?

Can you get a needle nose pliers on the connector, squeeze the tab and then pull it off? I just had to do this for the oil control valves on a Lexus.

Tester

I’m unfamiliar with the Altima setup, but I’'ll throw out a general idea anyway.
Would it be more accessable if yout went at it by removing the wheel and the inner wheelwell liner (commonly called the “apron”)?

Re: Tester’s point, I have numerous variations of needle nose pliars just for this purpose. I have some spark plug wire plairs that give me an option too. A browse through the pliars section of a good tool store might just turn up something perfect for your task.

Wheel well might open up some options. I’ll look into it. Good suggestion.

I can’t really squeeze the button with pliers. It has to get pushed in towards the engine, while the connector has to be pulled away from the engine. I have to push the button in the exact opposite direction of how I’m trying to pull the connector!

Maybe I could push the button with the tip of the pliers then squeeze and pull back with the jaws of the pliers. Hmmm…

Perhaps surgical forcepts might work. You could squeeze them down on the release tab and they’d stay squeezed while you pulled the plug out.

Let it be publically known that removal of the inner wheelwell (“apron”) is the commonly accepted way to access the front of transversely mounted engines.

Good advice above. Also consider using a dental mirror gadget and good lighting to see what it is exactly that is holding it in place. It is probably just stuck from being on there for 10 years, and needs a little tender persuasion. Also look at the other connectors you can more readily see for a guide on what is needed to remove them.

When I have a problem like this, and a few minutes of fiddling doesn’t work, I’ll often start removing other stuff which is in the way, rather than fight it.

Spent a few more hours on it. Still can’t get it. What should I take off first: the motor mount, the firewall, or the bell housing? Ack!!!

I’d try surgical forcepts. You can get them in all kinds of bends and angles.
You’re probably already aware of this, but you know you have to push the connector in before squeezing the clip, then pull with the clip squeezed. It sounds like that’s what you’re doing, but I had to ask.

There’s several links by Googling “How to replace altima crankshaft position sensor”, the one below shows where it is. A different year altima from yours though, but from what you say, they seems like they are still in the same place, where the engine and xmission meet.

I looked at that vdo and was reminded of my problem of replacing the starter motor in my 4AFE Corolla. It is in about the same position as your sensor. I struggled with the drive shafts obstructions and bell housing and various other stuff by trying to do it from below. Then someone here in this forum suggested it could be done from above. Good idea. All I had to do was remove the battery and air cleaner and the ducting from the air cleaner to the intake manifold, and a couple of hoses, and the one-man removal and installation became quite simple. Maybe that’s what you need to do, and maybe get a little help from someone, so you have someone above and below.

Here’s an aside which might be amusing, but probably not helpful: One time I took a golfing lesson and the instructor watched me hit the ball left, right, rarely down the center. Finally he told me George, there’s a lot of rules in golf. But you ARE allowed to aim!" It turned out the only problem I was having was that I wasn’t carefully setting up and aiming. I was concentrating on the swing, and not the aim. Voila, A little aiming works wonders.

I mention this only to say that just because you don’t have the right tool in your tool box, it doesn’t mean the right tool doesn’t exist to do this job. You may have to make it though. A stiff piece of wire bent in the right configuration may be all you need to extract that stubborn connector. Also, remember that you are allowed to turn the steering wheel. Maybe moving the steering one way or the other will open up some room down there where you need it. Best of luck.

I finally got it changed. The secret was a simple pair of slip joint pliers. The jaw was wide enough that I was able to hold the green button in with the tip, while pulling back on connector with the jaws.

Unfortunately, it’s still throwing the same code! Ugh. And now it is hard to start. So I just made it worse.

The resistance on the old sensor was about 1200 ohms vs. a range of 432 to 528 ohms in the Haynes manual. Of course, the manual also says that sensor is only used to detect misfires. So I’m not sure. I don’t know how to test the voltage on the sensor because of it’s location.

I read about so many problems with the Altima crankshaft sensors. They had to redesign them and the replacements are now made out of metal instead of plastic. I was sure that was the problem!

It made a gratifying click when I connected it, but I’m still hoping maybe I can just push the connector on a little further. Have to wait for the engine to cool down, though.

The crank sensor not only detects for misfires, but it also informs the computer whether or not the engine is rotating. If the computer doesn’t detect that the engine is rotating it see’s no reason to operate the ignition or the fuel injection systems so the engine won’t start.

You may have installed a bad crank sensor.

Tester

As Tester says, I don’t think the sensor on your car – despite what that manual says – is only used to detect misfires. It is used to detect misfires, but its primary function is to define engine and ignition timing events. Make sure the new one tests ok is the first thing. It’s possible the parts place may have given you an incorrect part number too. The fact that the car now runs poorly indicates the old one may not be completely broken, but intermittant, and now the new one is no good at all.

It’s hard to say what that resistance measurement you made means. It depends in part of whether it is an inductive type or a Hall effect type. Does the manual say what type it is? The inductive type is just a coil of fine wire, so as long as it doesn’t read a completely open circuit, I’d expect it to still work. If it is a Hall effect type though, I’d expect it to be bad. Of course even if it an inductive type, it might be ok when cold, but open up (& fail) when warm. Have you tried the experiment on the old one while heating it with a hair dryer? It’s not an uncommon thing for them to fail when hot but work ok when cold. I had something similar (the inductive crank sensor part of the magneto) on my lawnmower that failed this way in fact.

It’s also possible the connector has been damaged or become dirty or corroded. You may have to ohm the connections out from the flywheel to wherever it connects up next in the wiring diagram to make sure you are getting the signal through to where it goes.

Well… I got a second replacement sensor. It tested the same resistance as the first one. Not a good sign. I bent two pins trying to hook up the connector. Got it out again. Straightened the pins, put it back in again. Dropped the bolt somewhere in the engine compartment. Spent an hour fishing around with a magnet. Can’t find the bolt. Cleared the code and tried to fire it up anyway. Code still comes back. Still can’t find the bolt. So now I just have a hole in the engine.

How many hours did I spend on this bugger? I think it’s time to call it quits and bring it to the dealer. Ugh. Major ego blow.

Can I drive the car with no crankshaft sensor? Or do I have to get a tow truck?

You almost certainly WILL NOT be able to start the car with no crankshaft position sensor. That would be unheard of.

I would be worrying about the bolt. You don’t want it to wind up somewhere where it’ll cause problems.

I started it up and drove it up the ramps to look for the bolt from the bottom. I drove my wife to the train station with the thing completely unplugged. It takes a few extra cranks, but starting without a crank sensor does not seem to be an issue.

Not too worried about the bolt. Probably just wedged in next to the engine mount. There aren’t a lot of moving parts in that area.

Are you sure you’re not talking about the camshaft position sensor?

Cars aren’t supposed to start without the crankshaft position sensor?

Cars will start without the cam sensor, but it will take longer.

I wish it were the camshaft sensor. That would be a hell of a lot easier to change! I guess the computer must be smart enough to impute the crankshaft position from the camshaft data.

You are quite fortunate.

Took it in to the dealer today. They stuck the sensor in and charged me $140. Problem solved.

They took off the intake manifold which is basically what George suggested. I never took off an intake, so I was afraid of opening up another whole can of worms. I didn’t want to wind up with vacuum leaks and stuff - especially since I wasn’t sure that would help. The sensor is still way down in there. In the video, they didn’t take off anything. But apparently that’s the secret.

Thanks everybody for all your input!