94 Ford Ranger new ignition key lock cylinder won't turn to lock in place

ford
ranger

#1

I easily removed the key lock cylinder but when I went to put the new one in I cannot get it to turn all the way back to lock the pin in place. The steering wheel is not in the locked position nor can I get it to lock. I have turned the steering wheel as far left and right as I could go with no success on getting it to lock or on getting the ignition key lock cylinder to turn back securing the actuator pin. I need help. The old key lock cylinder won’t go back in either. What am I doing wrong?


#2

You haven’t gotten the rack in the correct position to engage the lock cylinder. The ignition switch must be in the fully locked position and the lock cylinder installed at the lock position to get the key to operate the switch. It can be an aggravating job but there’s no way around it.


#3

I have tried the only position it will let me do. The little button doesn’t go down unless it is in the locked position. Then it will only slide into the hole one way. After that I have tried go both ways and working the steering wheel. Nothing is working. There is nothing wrong with the cylinders. The components inside the steering column where the end of the cylinder slides into seems loose to me, but I don’t know if they should be tight or not. Are their bearings in there? If so, they may have come loose when I removed the old cylinder.


#4

I figured it out. I also replaced the ignition switch on the lower shaft. On the ignition there is a slide mechanism that you have to push to the same side as the one that was removed before reattaching it to the steering column. I missed that step in the manual. As soon as I did that the new key lock cylinder worked like a champ. It is a lot tighter than my old one but that should get better over time and I might spray some WD-40 on it. I hope this helps someone else in the future.