'92 Buick Century w/replaced throttle position sensor still stalls out

SO, my Buick has given the code for bad TPS, and it was replaced a little over a year ago…and now after the same symptoms, replaced again… However, this time, right after replacing, it gave the code again, and still stalls out /doesn’t want to stay running especially when put in gear. My regular mechanic also recently just put on a new catalytic converter and a new fuel pump and fuel filter. I’m at a loss, and desperately need my car back.

A little back history…about 3 years ago a ‘friend’ was to work on my car to install the thermostat and powerwashed the engine…which shortly after started having all kinds of electrical issues. Right after that, my mechanic had to install a coil, spark plugs, new ignition panel and the 1st tps.

Any and all thoughts ideas will be much appreciated! :slight_smile:

Might want to check and clean the connector and check the wiring. The code just means its in the circuit somewhere. The computer doesn’t know if its the tps or somewhere else in the circuit. Also when a GM of that vintage starts having stalling problems you could be looking at a lot of other stuff such as EGR, crank sensor, etc.

The next time you go to start the engine, slightly step on the accelerator and then start the engine. If the engine starts and runs the problem is probably with Idle Air Control valve. http://www.rockauto.com/catalog/moreinfo.php?pk=950858&cc=1015962


Tester, that has been tried, and it doesn’t work. Thanks for your post.

I’ll add this: my mechanic said to kind of pump the accelerator pedal when it wanted to stall or slow and that worked a little bit, but it got progressively worse, and on the last day I drove it, it stalled while I was going 50mph because I took my foot off the gas pedal to slow down.

Anybody else have thoughts or suggestions? Please? Im taking every idea I can get. Wish Click & Clack was still on air.

A little more information.

What engine, and is the engine throttle body injected?


Sorry I missed this comment. It’s a 3.3 V6…and unsure about the engine throttle body.

If you’re getting the code again for the TPS and it’s just been replaced, one of these must be true:

-The new TPS is bad. (quite possible, as some aftermarket parts are junk–maybe try an OEM one next)

-The wiring harness or connector has a problem, as Tester has said.

-The ‘computer’ itself has an internal problem.

On a car that old, you could indeed have other problems, and being a 92, it has OBD1, which did not include nearly as many checks or diagnostics. So not having any other codes come up doesn’t necessarily mean there are no other problems. But the system is certainly bright enough to tell when your TPS is out of range. What exactly does the code you’re getting say?