2007 Dodge Ram 1500 5.7l with "no bus" error and won't start

My truck is showing a “no bus” error with several dash warning lights staying on, including security light. It will not start and seems like the security immobilizer has kicked in (won’t even turn over).

This started just after I replaced the a/c compressor. We found out that the coolant had not all leaked out when my nephew removed the lines. It sprayed around the engine compartment. At first, I was able to start it the next day but when I shut it off and tried again the error message came back. It also started a couple more times but shut off within 10 seconds.

Dash lights all seem to work, but controls on the steering column don’t function (no 4-ways, turn signals, etc). The radio does not work and it doesn’t seem to respond to the headlight switch or transfer switch either. Didn’t think to test the horn.

Windows and door locks all function.

I’ve tried to make sense of the rat’s nest under the dash. Tried to see if there’s power coming in with a check light for the 4 ways. There is a connector there that has 4 wires, 3 show power coming in. Not sure why it would need 3 powered lines.

OCB2 codes show U1403 (twice) which is for fuel level sensor. Don’t see why that would be a problem.

Sometimes the alarm sounds when the door is open with the key on, sometimes not. The headlights usually come on and stay on until the key is turned off and door closed (after 30 seconds).

I took out the battery. It is possibly the cause of the problems as it doesn’t seem to hold a charge anymore. I tried a deep cycle boat battery to see if it made any difference but no dice.

I removed the TIPM and cleaned the connections. There is one connector that has corroded but I don’t know what it controls. Since I’m getting power to the 4-ways, I suspect it isn’t a power issue, but I could be wrong.

I removed the battery tray and visually inspected all the wires from the dash to the TIPM and/or grounds. I found a couple wires that had been abraided, but not broken.

I’m at a loss of what to check here. I know it could be the PCM or one of the wires running to it along the firewall, so I’ll have to check those as well. But the only tools I have are a check light, multimeter and my weary eyeballs. I have no idea how to check the PCM or TIPM and I don’t want to spend money fixing something that ain’t broke ('cause I am).

Is there anyone out there that can help me diagnose this? What should I be checking? Do the dash indicators that stay lit have a clue to help?

Thanks for your time and help!

wires could of shorting out. especially when freon and lubricant went flying around engine bay wetting everything. when power was restored the electricity had a path to jump through the fluid. just my thoughts. also check all fuses and relays.

Hi weekend-warrior. How would I test for shorted wires?

I have checked the fuses in the TIPM, but I’m not sure where the relays would be for this truck. Any suggestions?

your owners manual should show you location and pictures of relay locations

You searched for 2007 Dodge Ram 1500 fuse diagram • FuseCheck.com

I expect you’re going to need to find someone with a Dodge scan tool to fix this. However, there’s one thing I’d try if I had that problem first.

The radio not working may be what is preventing you from starting the engine. On newer models the radio is often part of the security system. Double check the radio connections.
Once you think you have all the connectors connected correctly, and you still got a no-go, try completely disconnecting the battery, both clamps, and let it sit overnight. Reconnect the battery. Might work if the problem was that all the computers just needed a hard reset.

Sounds like this may be the TIPM gone south. It would be worth a shot to try to reset it. This helped restore some functions in my '07 Ram.

Not in this case. Plus, the security system would not prevent the motor from cranking.

1 Like

Thanks weekend-warrior, George_San_Jose1 and NYBo. I’ll check some of these things this week.

Inspect for damaged wiring near the A/C compressor and other areas of recent repair. If the 5 volt feed to the engine sensors is shorted to ground, the PCM will shut down and a “No BUS” message will be displayed.


Isn’t the pcm on the firewall in the general area of the AC accumulator? I seem to remember it was on my 98 Ram. May be mistaken or they may have moved it on later models. Wondering if a shot of Freon and oil couldn’t have found its way into the connections to the pcm. Might it be worth a shot cleaning those connections and reseating them?

Thanks Nevada_545. I’ll check those wires.

Yes, it is there on the 07 as well. I’ve removed the connectors and given them a good cleaning with electrical cleaner, but it didn’t seem to make a difference. It could be a problem in the PCM itself though. I’ve looked into the prices for a PCM or a TIPM for this truck and if those are the problem I may have to scrap it. Not sure if I can go used with those parts and the new prices are just too steep for a 14 year old truck.

1 Like

Just an update… did a hard reset of the TIPM as suggested by @George_San_Jose1. Took the battery out and charged it overnight. I have a smart charger and it took a lot longer than it should have but it did fully charge. Put it back in this morning and no joy. Same problems happening. I guess it’s back to checking wires for now.

There’s a lot of wiring in a 2007 Dodge Ram. My 70’s Ford truck, the entire wiring schematic fits on 2 1/2 pages. My 90’s Corolla, over 200 pages. Think how many pages your truck must require. So if still no joy after checking the wires, consider taking your truck to a shop w/the appropriate scan tool. If the shop’s personnel are skilled in vehicle-computer diagnosis, that method is pretty likely to get to the bottom of it. BTW you aren’t required to allow the shop to do the repair. You can ask for a diagnosis only if you want, then you do the repair yourself. There’s some downsides to this approach, but even so it remains available to you. Best of luck.

Your truck wasn’t involved in any jump-starting activity recently, right?

My dad has a friend who deals in used cars, and he has a go to guy for all things electronic (not just automotive either). They made the 2 hour trip up here today and he had it fixed in about 2 hours. It turns out that the one bad pin I’d found on the TIPM was a major communication line (hence the “no bus”). He had hooked up his computer and found only 3 of the truck’s modules were communicating with the PCM.

Taking the TIPM apart, he soldered a wire onto the back of the motherboard where the broken pin was connected. He routed that out through a small hole in the casing. He cut the wire at the connector and connected it directly to the soldered wire. We put everything back together and everything functions perfectly now.

What a relief!

I guess that it is really important to know the right people with the right tools.


Glad you are back on the road again. The shop seemed pretty creative in their approach, so they are likely very experienced in this sort of thing. It may be near-impossible to find replacements for these older modules, so the only way to solve the problem is w/creative wiring methods.

I had sort of a similar problem years ago. On my prior VW Rabbit I had to re-route a wire around a broken buss-bar which was inside the fuse box.

1 Like

That is true for a lot of aspects in life.