2006 Trailblazer wont start.. Please help

chevrolet
trailblazerext

#1

2006 Trailblazer I6 LS 2WD after market remote start

original issue: PS pump failure. Also, RR. Rack and Pinion

After installing the above mentioned, i go to start the vehicle to run the power steering pump. When turning the key and cranking the engine, i notice large amounts of smoke from the exhaust. Also the engine idled very rough so i turned the key off and shut it downed. The engine probably ran at most 5 seconds because i opened the key several times during the original repairs to close windows etc… I assumed i created a flooded condition and the smoke was just excess fuel burning out. I tried to crank the engine again but this time it was a NO START. Since the car has sat for several days over Christmas in freezing temps, i decided to disconnect battery and trickle charge to bring it up to full voltage. While the charger was doing its thing i decided to pull the spark plugs to inspect and allow gases to dissapate. The plugs seemed fine but flooded with unburnt fuel. I cleaned them all off with a wire brush and reinstalled. Then the battery was ready so i reinstalled it. At issue, Vehicle cranks but NO START. Checked all relevant fuses (10,22,23,28,29 and 47). All seemed visually intact no over heating marks.

Added heet to the fuel tank and additional 5 gallons of fresh fuel. With key turned on, i can hear the fuel pump priming although it sounds odd. Again ive pulled the spark plugs and they continue to flood.

With a test light, i verify i am getting spark to spark plugs while cranking. The plugs have about 10,000 miles on them. Otherwise seem in good working order. Keep in mind, the engine ran perfect before RR the steering system.

After some research, i pulled the throttle body and cleaned it with carb cleaner and wire brush. The butterfly valve moved fine with some finger pressure. Did not notice any damage or sounds of loose parts inside. Reinstalled all intake and performed a throttle relearn process (11 minutes key on 30 seconds key off X 3).

No cluster lights On except for MIL.

I am unsure if this issue has to do with passlok. I do not see the car with a lock light on the dashboard.

Attempted to start the engine with transmission in nuetral position, expierenced same crank. NO START.

Looked around engine compartment for any loose connectors or loose grounds or grounds in bad shape. I have not cleaned the MAF sensor. I have not measured the fuel pressure although from the flooded plugs i can tell im getting fuel. Unfortunetly, i do not have immediate reach to a scan tool to pull any codes.

Has anyone expierenced this??

Can i pull any trouble codes some other way then scan tools??

Keep in mind that engine hasnt been started for a few days while serpentine belt has been off and weve had below freezing temps.

PS. Stuck at inlaws house for a week and a half… They live out in country so please… HELP.

THANK YOU.


#2

I would advise removing the “after market” remote start. They are usually the cause of most no start conditions when installed.


#3

My off the cuff smart aleck answer is. It will not start because you have an l6 in a vehicle that has an ECU for a V6 which is what your vehicle came with. :yum:
On the other hand it could be the after market remote start, they are the cause of many head aches. Or you could have knocked something loose doing the work you did. Check and recheck every connector and wire in every area you work in.


#4

To my knowledge, no. Do the in laws know anybody with a reader? You might check with the parts store in the nearest town, see if they have a ‘tool rental’ for scanner - you buy it, use it, return it. That might be an item that is not part of that program, IDK.


#5

Not a V6 @PvtPublic The Trailblazer has a DOHC inline 4.2 liter inline 6, A dandy motor, BTW.


#6

I’d sure blame the aftermarket remote starter, too but it all sound pretty strange. You have fuel and spark so why isn’t it starting?

Too much fuel? Bad fuel pressure regulator? They usually fail low, or not enough fuel, this problem seems to be too much fuel. Ecu failed and is commanding full ON for the injectors maybe? Check the PWM output commanded to one of the injectors.

Sure would help to scan the codes and report back.


#7

Thank you. I am on my way to give it another go right now. I will definately keep you posted in a bit.


#8

Hey @Mustangman

Update.
Bought a basic scan tool.
No DTCs stores!!!
Erased codes anyways.
MIL still illuminated, wont go away.


#9

Does anyone know the bonafide Chevy process on relearning the throttle position sensor for this truck?

With the intake baffle off, can see the throttle valve doesnt move at all while cranking.

It does flicker all the way shut when the key is first turned to On or turned to Off.


#10

I assume you could see the throttle plate open when someone pushed the gas to the floor. Have you tried starting it with it floored? This shuts off the injectors to start a flooded engine.


#11

Did attempt wide open throttle and crank. But maybe it was already too flooded.

Will probably buy new plugs and let the cylinders air out meanwhile. Maybe the plugs just cant keep up with the fuel dumped in on a cold start.

Also. Havent checked if the valve opens with the pedal. Another to do.


#12

Note that if this is a wireless (cable-free) accelerator system, the key will need to be in the ON position for the ECU to sense the pedal position and move the throttle plate accordingly. I’m not even certain that it’ll do that with the other engine demand signals not being received. Perhaps others here who know can comment. I too would like to know the answer.


#13

I had a weird experience with my 03 trailblazer, I started it moved it up 6 ft turned it off and the next day no start, cranked fine but would not run. So every 5 or 10 minutes kept trying to start it and no go. So I put a battery maintainer on as I was killing the battery, tried starter fluid, no kick, and being anal retentive wanted to keep trying till it started vs getting it towed to a shop. Now I am sure you can imagine after an hour I am pumping the pedal, cursing and giving my car new names, but maybe an hour and a half later got a stutter, more cursing and battery charge, better stutter, then it started and has been running fine for 3 years since.

I do not let it run less than a couple of minutes since then, science or superstition I do not know, just stuff that works.

No codes!

Maybe reset the brains?


#14

@Barkydog

I am starting to think this car is cursed. Ive checked everything and just floored it and still no turn on. I was 100 percent sure it was going to turn on but didnt.


#15

@insightful

I am starting to think this car is cursed. Ive checked everything and just floored it and still no turn on. I was 100 percent sure it was going to turn on but didnt.

Any other suggestion?? Can’t tow it anywhere.


#16

No turn or crank is a battery power connection problem, I had the rubber boot on the side post terminal I ended up cutting off with an exacto knife because somehow the rubber protector grew and was preventing a good connection. Please clarify no crank or no start, thanks


#17

@Barkydog
To clarify,
all thruout it’s been:
Engine cranks, but no start.

Since last post,
*Replaced plugs w new platinum plugs, gaped to specs.(.043)
*Confirmed throttle valve responds to gas pedal
*Cranked, initially sounded like engine catching, but quickly seems to flood
*Pulled plug and confirmed wet w unburnt fuel
*Called the CS# on the remote for the remote start company. Closed for today.
*Still not throwing any stored DTCs
*Engine does not sputter out or back-fire
*Battery on a trickle charge
*Starter cranks and cranks like a champ w battery fully charged

How can I check ignition timing is correct?

Am missing anything?

All help appreciated.
Will absolutely post the fix once resolved…


#18

Issue was steering.
Did it run before u did work?
Usually if u have owned it awhile u might say it ran great for 2 yrs before I worked on steering.
Did u buy a non running truck due to steering issues?


#19

@Cavell

It ran perfectly fine until power steering pump started leaking.
Took a couple days to switch out rack and pinion and brand new pump.
After switch, vehicle cranks but no start.


#20

You said you have a basic code reader and the MIL light is still on. Does it display a code?