2005 Isuzu Pickup doesn't crank or start

pickup
isuzu

#1

My isuzu kb 300 engine check light does not come at all when car is at on position and other dash lights will be there…further more the vehicle does not start or crank at all.


#2

Battery connections are the first place to begin when you have a “No Crank” situation. Even
if you have a new battery, if the connections are loose, dirty or corroded, you will not be
allowing the full flow of current to pass thru the connections. The connection may be
enough to turn on the lights, but not enough for the huge flow that is needed to operate the
starter. This is where many people say that they know the battery is good….”because the
lights come on”. This is no more a battery test than licking a 9volt battery. It only tells you that there is electricity…not how many volts or the amperage that flows from the battery.
Jump starting may have wiggled the terminal just enough to allow the current to pass and start the engine, but tomorrow you have the same problem.

First remove the cables from the battery and use a wire brush to remove any corrosion and dirt from the battery posts and the cable terminals. There is a tool with a round wire brush for this purpose, found at any auto parts store for less than $10 http://shop.advanceautoparts.com/p/kd-tools-terminal-battery-brush-kdt201/25980576-P?searchTerm=terminal+brush.
Before connecting the cables, apply a coating of di-electric grease to the battery posts this will keep oxygen away from the connection so that it will not corrode as fast.

It is just as important that the other end of the cables also have a clean connection. Remove the negayive cable from the battery again so that you do not short anything out. Follow both cables to their far ends, remove this connection and wire brush the connection and the cable terminal clean and retighten these connections.

If there was work done recently, there may have been an “engine to body” ground that was not installed following the work. These grounds normally run from the rear of the engine to the firewall and are uninsulated and most are a braided wire. If any of these are found unattached…reattach them.
Remember….this is not a “Sherman Tank” don’t over tighten the connections.
Tight…tight………………too tight…broke!!!

Yosemite