2002 Mitsubishi Lancer Electrical Problems


#1

Good evening all,

I’m really puzzled by the electrical issue I’m having with my wife’s 2002 Mitsubishi Lancer. It’s got a 120,000 miles and we’ve owned it since new. It has had almost zero problems up until this point.

The other day, my wife calls and says that her A/C isn’t working, it’s just blowing hot air. When she got home, she turned the car off, removed her key, and noticed that the climate control blower was running. She turned it off and went inside. She had the radio on

When I came home, I verified that with no key in the ignition, turning on the blower motor switch did turn on the blower motor. I started the car and immediately noticed both the condenser cooling fan and the engine cooling fan both immediately started running. I turned on the A/C, got nothing but hot air, and verified that the compressor was not turning.

I turned the car off and decided to check for fuses. When I pulled the A/C fuse under the hood, I heard a loud CLICK from the A/C compressor area. When I reinserted the fuse, I received another click. I then pulled out the A/C compressor clutch relay, and heard the same click. Since I wasn’t sure if it really was the A/C clutch, I asked my sister-in-law to plug in and unplug the relay while I put my hand on the compressor. She did it several times and before I could verify it was the A/C clutch…it stopped. At this point, unplugging the A/C compressor relay would not cause the click. Also, unplugging the A/C fuse would not cause the click.

I then turned on the blower motor (key still off!) and it didn’t start running. I started the car, and the A/C worked fine! So I drove 50 miles back and forth to work the next day and figured it was some sort of fluke.

This morning I get a call that her battery is dead. I get home, put the charger on it, and as soon as the voltage came up a little, there was the click from the A/C clutch. Unplugging the A/C clutch relay caused another click. Relay in - click. Relay out - click. Same with the A/C fuse. Then, like before, plugging the relay or fuse back in no longer caused the click.

I do have the service manual and looking at the wiring diagram…the blower relay coil can only get power with the key in ACC or RUN. The A/C clutch is more complicated…it gets power from the SAME source - the ACC or RUN position on the ignition switch. But, ground is through the engine management computer (car is a 5-speed).

The only thing that seems to be common and could explain everything would be a bad ignition switch - the blower and A/C compressor power, plus the engine management computer all seem to be on the same contact on the ignition switch. The service manual ignition switch schematic is very confusing.

Any thoughts? I don’t want to throw parts at it…but that seems to be the only thing that makes sense?

thanks much,
ben


#2

It looks as if a bad relay is causing your problem. Here is your AC clutch diagram.


#3

Good afternoon!

I spent the morning drawing up a diagram that incorporated the ignition switch, fan relay, compressor clutch relay, A/C computer, and blower switch. I now agree with you - I believe I have a bad relay.

thanks much,
ben


#4

Looking at the diagram @knfenimore so nicely provided it shows power to the AC relay comes directly from the battery, not the ignition circuit. If the relay contacts are sticking that will cause the issue all right but maybe something is turning on the relay. To prove that, check the voltage across the coil of the relay on pins 2 and 3 while the trouble is happening. If there is voltage on those pins then something is turning the relay on. A faulty ECU could be the cause or a bad ignition switch possibly.


#5

I had a fuel pump relay stick on a 70’s VW Rabbit one time, and the symptom was similar. When I put the key in and turned it to “on”, but before I cranked the engine to start it, the fuel pump would come on. I took it to a VW shop, and they told me tat is how it is supposed to work. So I asked them to prove it, take me out into their lot and do the same thing on another Rabbit. No fuel pump sound with the key in “on” and the engine not started. Replacing the fuel pump relay fixed it. I took the old one apart and found the contacts were welded.