1997 Geo Metro Won't Start Once It Warms Up


#1

First time user here, have done several repairs to my vehicles, but I’m still a greenhorn when it comes to general car operation knowledge.

My 1997 Geo Metro with a 1.3 Liter will start when the engine is cold but once it warms up it refuses to start. I’ve replaced fuel filter and fuel pressure regulator, and checked to make sure the fuel pump is working and it is. I think I’ve narrowed it down to the fact that the fuel injector is not pulsing. It will fire when I prime it, but dies immediately. Hoping someone may have some simple suggestions that I haven’t thought of yet.


#2

Does it act the same whether or not you push the accelerator while cranking?


#3

You might want to check the fuel pressure. Especially the residual fuel pressure.

The residual fuel pressure is the pressure that remains in the fuel system once the fuel pump shuts off. This is done so when the hot engine is turned off the heat doesn’t cause vapor lock in the fuel system. If vapor lock does occur, it makes it very difficult to get a hot engine to start.

To check the residual fuel pressure, connect the gauge, and then turn the ignition switch to on to run the fuel pump. Then watch how quickly the fuel pressure bleeds down. It should normally take fifteen minutes to a half hour for the residual fuel pressure to bleed down. If the gauge immediately drops to zero when the fuel pump stops running, the heat from the engine is causing vapor lock because there’s no residual fuel pressure to prevent it.

Tester


#4

Unfortunately, I don’t have a gauge. I just did the old fashioned check of the fuel pump to see if it pumps fuel to the Throttle body, when the key is turned on. And I assumed it’s working well, since it will run fine when it’s started cold.

And, yes, it acts the same whether I pump the accelerator or not.

Other things I’ve tried include changing throttle position sensor, MAF / MAP sensor, Temp Sensor, Crank Shaft sensor, (all from junk yard).


#5

The first thing I would do is start buying a few new parts.

When it comes to electrical components…how do you know the one from a junker is any good.
It’s one thing to purchase a used fender or a drive shaft…you can pretty much see that they are ok…though the driveshaft could be bent. But buying electrical components that run the engine…no!!!

I’d start with the Crank and temp sensors…NEW… and see if the problem goes away.

Are you sure it is a 1.3…Advanced Auto Parts only shows a 1.0 for the 1997. Or did you add an extra squirrel under the hood.

Yosemite


#6

Definitely don’t throw the old parts away. Replacing parts even is a relatively simple car like the Metro, with a modern engine like it has you can run out of money before running out of ideas.

Is the check engine light on? Have you checked for any stored diagnostic codes? If not, that’s the place to start.

When you say it fires when you prime it, do you mean you spray some starter fluid (like ether) into the intake manifold, then it starts ok, but only runs for a few seconds?

What makes you think the injector isn’t pulsing? Which injector? Just one of them? Or all of them?

I’m suspecting a heat sensitive electrical component. If it is sparking ok, but none of the injectors are firing, as the OP suspects, it could be the ground for the injector solenoids. Make sure that is solid connection to the chassis. If not that, it could be a bad relay or fuse in the fuel injector control circuitry. Those can fail when hot, but work ok when cold. You probably have a main fuel injector relay, so try tapping on that, see if it helps. Better yet, remove it and test it on the bench. If none of the above, check the connection at the ECM connector.

You might want to bring in a tech to help you diagnose this problem. Diagnosis a no-injector pulse condition really requires a lab scope to look at the injector control pulses.


#7

I replaced the Idle Speed Control Motor and that seems to have solved the issue. I did notice, as I continue to research possible culprits etc. that the previous owner has completely bypassed the EGR system. The valve is missing with a simple metal plate in it’s place covering the two holes for the EGR valve. I’m sure that probably plays into my issues as well. Thanks for your suggestions gentlemen. I appreciate you taking the time to try and give me a hand.


#8

Glad you got the no-start problem solved. That’s not a common way to solve hot-soak start problems, but it’s good to know it worked for you at least.

I doubt the EGR has anything to do w/your symptom. But the last owner removing the EGR could potentially cause you problems down the road. I mean besides not passing emissions testing. It’s primarily an emissions device, but part of its function is to cool-off the combustion chamber a bit during heavy accelerations, going uphill, pulling trailers, etc. Anything placing a big load on the engine. Without a functional EGR you may risk overheated and burned valves, damaged spark plug electrodes, cracked exhaust manifolds, and maybe even engine overheating. If you start to notice any of those, suspect the missing EGR.


#9

+1 to George’s post. His advice is good advice.