1996 Caravan blinking CEL, garage stumped


#1

My 1996 Caravan (3.3 liter engine) had the CEL come on two weeks ago. We took it in, code said multiple misfirings. Spark Plugs and wires were all good (only 10K miles), catalytic converter checked out fine, so garage (dealer) cleaned the fuel injectors and reset CEL.

Not 10 miles later, the CEL comes back on, but this time it is blinking. Van runs fine and is very smooth. Took back to dealer, and they are stumped. It’s been there the last two days and they can’t figure out what is causing the CEL to trigger and blink.

Any ideas?


#2

A mechanic starts with the basics. What conditions, and sensors, indicate misfires? The crankshaft position sensor, for one.
Using a scan tool, a mechanic looks at the responses of the crankshaft position sensor, and the other sensors. A careful reading of those signals should indicate whether the misfire is real, or not; then, he decides what to do.


#3

The mechanic said there is no misfiring. I’m not sure what all has been checked, though. DH said he drove van about 10miles tonight, CEL is lit, but not blinking currently.


#4

If you have the van back in hand I would suggest dropping by a local AutoZone, Checkers, Advance, etc. and have them scan the vehicle. This will do this for you free and it only takes a few minutes. Post any results back here for further discussion.

And never assume that 10k miles plugs and wires are good; other problems can cause those items to fail prematurely.


#5

Well, today DH disconnected the battery, let it sit for 30 mins and then reconnected it. The light is now off and has stayed off for 40 miles. So, we shall see…

Thank you for your feedback. If it comes back on, I’ll post the code.