1995 Camaro fuel pressure issue

Hi everyone, first post here.

I have an old 1995 Camaro, 3.4L V6 with about 170k. It was my first car, and I’m trying to fix it up. About a month ago I was driving it down the road a bit and back after finishing some work on it, and the engine completely shut off. Wouldn’t start after that. I found that there was no fuel pressure and no fuel pump cycling on at all. Therefore I figured the pump was dead after several years.

I bought a new Delphi pump, pulled the tank out of the car, replaced the pump, cleaned everything up and checked the lines. After putting it back together, I’m getting about 10 psi (instead of 44 or so) when you turn the key to the on position. The pressure would correctly go to 44 if you connected 12 volts to the jumper under the hood that bypasses the pump relay.

Since then, I’ve gotten a replacement pump, replaced the fuel pressure regulator, fuel filter, pulled the fuel rail and cleaned that/replaced the injector seals. The pressure is still low on key turn, and the new development is that it won’t even hold that pressure and now returns to zero after about 30 seconds.

Any advice?

Didja check the wiring to the pump?

You haven’t mentioned changing the pump relay, have you?

Yeah there is a connector near the rear axle that the fuel pump wiring goes to, and I’ve checked there is good 12V at that connector. Also checked the fuel pump ground. I also checked the continuity of everything when I had the sender/pump unit out of the tank.

I haven’t changed the relay, but I did check it with a multimeter. I would just replace it, but that doesn’t solve why fuel pressure isn’t holding anymore. Thanks for the responses.

It sounds like a bad fuel pump was installed,

When you turn the key, the computer only runs the fuel pump for a second or two and then shuts the fuel pump off. When you jump the factory prime wire, the fuel pump will run as long as 12 volts is applied to that wire. If the fuel pump is bad, this may be long enough for the pump to build the proper pressure.

Another thing that makes me believe the fuel pump is bad is, the fuel pump isn’t holding residual fuel pressure because of a bad anti drain-back valve on the fuel pump.

Try this. With the fuel pressure gauge attached, turn the ignition on for two seconds and then turn it off. Repeat this a half dozen times and then see if the proper pressure builds, and see if the residual fuel pressure holds

Tester.

Thank you for the reply.

Up until this recent development of not holding pressure at all, I was able to do that. While the direct prime connection went right up to 40+ psi, at the ignition I could turn the key, wait, turn the key, etc. and build the pressure up to the correct PSI in 3 or so key turns. Both methods would hold at the correct PSI after that.

The problem is I’ve had the tank out twice, which sucks, and this is now 2 new Delphi pumps I’ve tried. If this one is bad, it doesn’t seem like I should trust using one of their pumps.

Small update. I changed the relay and no dice. But for whatever reason when I turned the key a couple of cycles and built pressure up to about 20 psi, it did hold there. Given that the pump does hit 40+ psi when hit directly with 12V, I would think there is no fuel line restriction. Also, the wiring from the “pass thru” connector to the pump should be fine then as well. Perhaps there is a problem before/after the relay not getting enough power to the pump?

Old? Ha! Barely broken in :wink: Those early 90’s designs are golden, esp if it is OBD I.


Suggest to measure the voltage directly, by back-probing at the pump connector. I expect you have a burned or corroded connector somewhere in the path that powers the fuel pump. I had a similar problem with a VW Rabbit years ago. Bypassing the burned connection fixed it straight away. Finding where the burned connection is located, not simple. BTW a lower than designed voltage at the pump can damage it.

1 Like

1995 OBDI/OBDII were the bastard years for GM.

The paper clip method didn’t work to get codes, and a generic OBDII code reader couldn’t get codes.

Back then, it required a GM TECH II scanner to get codes.

Tester

Looking at the diagram, you jumped the fuel pump prime connector to +12 and got full pressure immediately? Then swapped out the relay so that’s not it. What’s left is ignition switch and wiring from there to pin 30 of the relay socket and pin 87 from the socket to A1. Check the relay socket pins as well. The wiring needs to be visibly checked as it can pass a resistance check but be compromised enough to limit pump current. You could try jumping your 12 volt to various points to try and isolate where the loss is occurring.