1989 chevy g20 van 4.3 turns over but won't start


#1

It was running fine. tried to start and it just turns over. also the fuel gauge doesn’t move from an 1/8th of a tank. i took the filter line off, turned the key, and gas shoots out but the injectors don’t spray at all. I poured some gas in the tbi and still just turns over without even trying to start. I’d appreciate any help


#2

Dead ECU? The fuel pump runs but doesn’t fire the injectors.

Did you check for blown fuses to the ECU?

Did you check to see if you have spark?

Did you try and read the OBD 1 codes with a reader or by shorting the two pins in the OBD 1 port? It should flash ONE pause ONE-TWO first and any codes follow. Code 12 just says the ECU is awake.

Check those 3 things and please report back what you find and we’ll go from there.


#3

If you must throw parts at the problem start with the ignition module. It’s not expensibe and can be replaced while sitting in the drivers seat as best I can recall. Use a small blade screwdriver to pry the connectors off the module before removing the module’s attaching bolts.


#4

Might be the “Return of the Spider” issue… Quite common on these engines/vehicles. How do you know the injectors are not spraying? Plugs stay dry while its cranking? Look into the "fuel injection spider’ issue I mentioned. I’ve repaired a fair share of those that needed a new spider…I dont know why they fail as they do…but it will just fail at some point…I think its the module that goes… You Should see a large plug that supplies the engine with all of its connections…sometimes when troubleshooting these vehicles it helps to unplug and reseat that large plug at the engine. Many times there is a small bolt that holds it in other times its plastic clips…but i would for giggles…unplug and re plug in that big plug and see what happens.

Then again…this is an 89’ so it may not even HAVE the spider !! Hmmm I have to look into that, I forget the exact years but it may have started in the 90’s with the spider…you might have throttle body injection on an 89. Sorry…I’m confusing myself with newer engines possibly. Its easier to troubleshoot if it does NOT have the spider anyway… Yes…I think my spider comment does NOT apply to you…89’ should be throttle body… Was a long time ago…LOL Apologies.

Have you tried a shot of starting fluid? What happens when you do ? If it tries to start after some Ether…then you know your on the right track with fueling and not spark.

All the other suggestions above are also warranted as well. Make sure your fuel is running AND is making the proper pressure as well…thats important. Let us know.

Blackbird


#5

@Honda Blackbird I think the 89’s still had the two-pot injector body style fuel injection. The one you can see the spray cone with the air cleaner off.


#6

Check for power getting to the injectors and the ignition system.


#7

Sounds like a bad ignition module, but I recommend checking for spark before proceeding. After you’ve reconnected the fuel line that sprays fuel everywhere.


#8

@Mustang Yeah I pretty much figured that midway through my reply. I’m getting OLD man…I’ve been around to watch the changes on so many engines by this time that I easily get confused when Im not right in front of something anymore. Its like the more I learn…the harder it is to wade through all the information up in my head. I need a better Admin of Information up there I think! LOL

Its easier with this style injection anyway…I hate those spiders…Hate them. The suggestions to look for spark/ Ignition module are certainly warranted. These are pretty basic systems in 89’…shouldn’t be too difficult to figure this one out.

Blackbird


#9

yes it’s got two injectors that should cone spray into it looks like two carburetors. the book says when the key is turned with the air cleaner off you should see the cone spray It doesn’t. spray. also I can’t seem to find the ignition module. I could walk to the parts store to go get one seeing it might help me find it


#10

I’ve drove it for 6 months and it has sometimes died or pumping the gas pedal got it back to running fine.


#11

ALSO I WILL TRY TO CHECK THE COMPUTER


#12

The ignition module is in the distributor.

enlarge the 2nd view. Replacement is quite simple and the module is the most likely cause for your NO START condition.


#13

THANK YOU


#14

You need to check the Fuel pump relay…it should prime immediately upon KOEO…Key all the way on …engine Off. You should hear the system prime before you hit the starter. Your vehicle DOES have an ECU…so… That thing could have bought the farm as well… they used to be a dime a dozen…but nowadays that thing is a classic car! You also have a crank sensor at the VERY least…Fi cannot function without a cam or crank sensor… Computer failures weren’t exactly common either…methinks you may have a bad relay a bad fuel pump or a bad crank sensor…Do some more homework… Look on the net for troubleshooting “no start on 89’ whatever”… Unless you have the service manual…THAT book will walk you thru a no start condition in the back of the book.

Blackbird


#15

it was the ignition module thank you so much i am up and running. you don’t know how badly i needed this


#16

Good deal. Thanks for the feedback.


#17

Yep…its been known to go. The guys here suggested that module straight away. Glad youre fixed up.

Blackbird