1950 Buick Special starts, idles, but dies when given gas...help?

buick
stalls

#1

From an idle, the car dies if I give it a lot of gas; however, if I slowly try to get the RPM’s up, it’ll run and I can rev the engine so long as the rpm’s are up.



Any thoughts on my problem?



I had the carburetor rebuilt, tank resealed, no work to fuel pump, could use new plugs and wires, did put on new points, distributor cap, coil. But I am by no means an expert mechanic.


#2

Back to the basics I guess. If it just stumbled some on acceleration, I’d say the accelerator pump but doesn’t sound like that. A fuel pump would likely give you low end performance but not at the higher rpm. So guess I’d be rechecking point gap. Was the oil cleaned off the contacts before installing etc. General spark condition. Other thing would be maybe the carb is set a little too lean.


#3

The way I read it, it does just stumble off the line so it is likely the accel pump. ClubHabel, take off the air cleaner and look into the carb with the engine running. Do you see a squirt of fuel going into the upper end of the carb when you work the throttle cable off idle position?


#4

If I recall correctly, that model car had a vacuum advance on the distributor, make sure it is working correctly. I beleive the distributor also had weights in it, check that these are not stuck.

I agree also with the accelerator pump.


#5

Did the 50s still have manual adjustable chokes on the engines?


#6

Some thoughts: Accelerator pump is the first thing I’d look at, (although that should have been replaced if the carburetor was rebuilt); then fuel filter; then check of the fuel pump to see if it is furnishing fuel at good pressure. You might also replace any flexible fuel hoses; sometimes these can deteriorate and begin to clog up or collapse under vacuum.


#7

The vacuum advance may be causing the distrubutor to ground the points. Disconnect the vacuum to the advance pot and drive it.


#8

I rechecked the gap a few times so I dont think its that. I’ll reclean the oil off the contacts. I could use new wires. I’ll see if the carbs too lean. Fuel is squirting into the carb so I dont think its the accelerator pump. I’ll look at the vacuum advance and weights. I dont believe the choke is manual adjust. Fuel filter seems fine. I did replace the flexibile part of the fuel hose. And I’m not so sure I know what disconnecting the vacuum to the advance pot means.

Someone else thought I may have a vacuum leak and will test for that hopefully by the end of the weekend. Thank you all for your thoughts.


#9

Hmmm. I think I would be checking the fuel pump for pressure and volume. I have a '52 book but not a '50 but believe the volume should still be 1 pint of gas in 30 seconds of cranking. The other thing I would be looking at is the float setting being too low or a leaky float that would weigh it down. Probably worth a look at the timing too just to make sure.

A vacume will normally have a specific sound if its that bad and really cause a rough idle. Worth checking I 'spose but doubt that’s it. The vacume advance would be that vacume resevoir off of the distributor and it would either have a rubber or metal vacume tube going to it. A mechanical advance just uses centrifigal force and springs. Again if tht were inoperative, I would think it would just give reduced performance since all it does is advance the timing. Why not just change those plugs and wires out to rule that out. Might be worth the extra $30 and might find they are in such bad condition they just can’t support proper combustion. That’s my two cents worth anyway.


#10

I followed the carb rebuild instructions to the ‘T’ when I tried to fix the same problem in a '65 Pontiac I had back then.

After I’d re-installed the carb and tried it out. The engine hesitated again.

What the …? Back to the drawing board. Dismantled the carb again and lo’n’behold, found 2 springs in the accelerator pump. They are so fine it’s hard to see one wound inside the other.

(don’t forget to replace the fuel filter too)

Once back together, no more problem. So maybe…?


#11

I’d look at the simplest and cheapest thing to replace 1st. Replace the plugs & wires then see what happens. Did you change the condenser when you changed the points? I assume that you did but I’m just trying to cover all of the bases. Having said that it sounds to me like either a vacuum leak or the air/fuel mixture on the carburator. One of the other posters mentioned the vacuum advance dash pot on the distributor. The dash pot (silly sounding name) is essentualy a pneumatic diaphram that is connected to the plate that the points are mounted on and it has a vacuum line attached to it. As the engine’s vacuum changes with the rpm’s the dash pot moves the plate thus advancing and retarding the spark. Check to be sure the vacuum line to the dash pot is connected. If not that would not only cause a vacuum leak and keep the distributor from advancing the spark at the right time.