CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

'02 Blazer Intermittent Fuel Pump

I have an 02’ Blazer 2Door 2WD 4.3L vortec. Great truck - very low miles. Sorry if this is long, but i want to give all the info - about a month ago the fuel pump went out. She was showing signs / not starting on the 1st/2nd try and finally wouldn’t start. It’s a 12 year old pump and I was also that guy trying to make til Friday on a quarter tank - so no complaints so far. I checked the relay and fuse, all good there - so I bought a new AC Delco and fuel filter. Drained and dropped the tank, cleaned and dried the tank and installed the new fuel filter. The pump came with a new pigtail - so I wired in the new pigtail, attached the hoses and re-attached the tank. Not bad for 6 hours of work ( first time - don’t judge ). She fired right up and ran like a champ / about a week later I stopped and filled up the gas tank. Next day - no start / no whine from pump / 0 psi at the schrader valve. Assuming it must be an electrical issue - I dropped the tank and tested the gray power wire / 12 volts. But to be thorough / in case I made a mistake / I stripped and re crimped all the connections, heat-sealed the sleeves and wrapped in all in electric tape. Tested the pump - she hummed like a kitty. Re-installed the tank and she fired up like a champ. Drove around a couple of days - stopped and filled the tank with gas. Same thing - wouldn’t start right there at the pump. i poured fuel in the intake - she would start and run until the fuel burned up. no hum from the pump. had it towed home … again … began to siphon my now full tank of fuel to drop it yet again. At about 1/2 way , I tried her and the pump primed and she started right away. For the past two weeks I have been unable to make it NOT WORK - but i am worried to go very far , less i be stranded again. on the gauge I get 60 with the key on and 56 running. With the engine off the pressure holds for quite a long time - well over an hour+. So what would cause a brand new AC Delco pump to not work only when the tank is full - then start working when some of the fuel is removed? Anyone else have this issue or have any suggestions.

A bad electrical connection at the pump maybe. Next time it happens, hit the tank near the pump and see if it runs.

I tried banging on the tank when it left me stranded with no luck / it would fire up with carb cleaner in the intake but quickly stalled when it burned up. Its as if the pump is getting no power when turned to on/cranking/running. But only with a full tank - I can go prime it now and get 60 psi - but the tank is only 1/2 full.

Having power to the pump is only half the story. What about a good ground at the pump. Does this have the ground wire from the tank that attaches to the frame? If the pump isn’t grounded it won’t run.

yes - I inspected ground wire / wire brushed the area/bolt that connects to the frame.

You need to check power and ground with a meter. Track it back. It could be a relay or ignition switch.

i checked the relay and replaced with a known working / guess it wouldnt hurt to replace with a new one. Would the ignition switch fail only occasionally? maybe the full tank is completely coincidence? How can I test the ignition switch? My only thought with the full tank was that it was changing the weight of the tank enough to cause the short.

If you can get to the pump wiring, you can pierce it and read across the hot and ground and read 12 volts. If you don’t get 12. Move the ground meter lead to the chassis and see if you get 12. If you do, your gnd is the problem. If no 12 then you can chase it back. Alldata.com has the schematics. You can subscribe for a small fee.