CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

U0101 Lost Communication with TCM

I have a 2010 Mazda 3 that recently showed a simultaneous check engine light and AT light. It was making a loud clunk sound when shifting into reverse and was stuck in what seemed to be 3rd gear (limp mode). The code is in the title. I checked the TCM visually and could not find any obvious damaged components. I had to peel off the resin to get to the board. So then I resealed it before putting it back in the car. Instead of replacing the TCM immediately, I plugged it back in and waited. The warning lights came back after a day or so but then the AT light turned off. It’s been intermittently going into limp mode and then back into regular shifting mode. The check engine light is on most of the time but AT light is off now. However the U0101 code persists. I am confused because if the TCM were not working why is it not in limp mode all the time? I bought a multimeter and checked the female connector to the TCM and discovered that pin letter I (as in iodine) was not receiving battery voltage with the key on. It was zero voltage. I then checked the wire going into that pin and it also had no voltage. Plus, pins 6 and 14 on the OSB2 read about 100 ohms, even though they are supposed to be 60. I checked the TCM fuse and AT main relay in the engine fuse box and they both were intact and working. If the wiring is broken somewhere I have no idea how to find it because most of the wiring goes into nomans land deep under the parts. I looked up wiring diagrams but I’m a bit lost regarding how to find the source of the lost power.

There may be another fuse involved w/the communication b/t the ecm and the tcm. I can’t tell from here, but check your owners manual, your wiring diagrams. I did some googling and found this for a 2008. Wouldn’t take that long to check all those fuses. In any event be sure to double check fuses associated with the ignition swtich, PCM, TCM, and OBD: both ignition switch fuses 11 & 13, tcm 27, pcm 30, pcm 36, obd 47,

1 Like

Thanks for the fast feedback! I checked most fuses, but I may have left out a few of the higher amp ones. I’ll look again. The 40 amp ones look a little different. Like a copper dot connected to another piece with a thin wire. I’ll see if I can get a picture. The fuse diagram is engraved on the underside of the fuse box lid, very convenient. So is this the order: battery, fuse box, fuse box connector with harness, and then to the TCM? Or is there another connector somewhere? The wires go from the fuse box into a dark pit of hell in a large plastic conduit with electric tape on it. Very overwhelming.

Do you think checking each fuse for continuity is better than just looking at the fuses?

If you are going to work on this yourself then you should invest in a factory service manual for the wiring. There is no substitute for this manual. It will show you all the information about the wiring and how it is run. Ebay is a good place to get them.

1 Like

I’ll definitely do that. Thanks!

If the related fuses measure good, then recheck you had good ground when checking TCM power input before tracing wiring.

Electronics do not always fail completely, they can act flaky as they progress to failure.

What did you use to replace the conformal coating?

1 Like

The TCM in the 2010 Mazda3 is sealed in a thick resin (silicone-like), about a quarter inch thick. I peeled that off to view the board, and resealed it with a silicone sealant. When I checked the voltage on the TCM connector I had the female connector and probed directly in the female pin hole. I placed the ground probe of the multimeter on the ground plate in the vehicle. I verified it was a good ground by checking the battery voltage using the same ground plate. I got 14 V, which I thought was high, but not sure. I also got about 14 V from battery post to battery post. I was able to get battery voltage on some of the other female pins, but that I pin had no voltage. I am going right from the Mazda spec sheet on what each female pin voltage should be for the TCM connector.

This is important, was it an acetic acid based RTV? Barring still having the tube to check, did it have a rather pungent odor or was it unnoticeable? The reason is, an acetic acid based product may have long term detrimental effect on the component leads and exposed vias/pads on the board. It can actually etch away the component leads, solder and board traces. It could do more harm than good. Just trying to help avoid any future problems that may result from an incompatible material used as a conformal coating…

Sounds like you had a decent ground point.

Yes. Looking is not always definitive. An alternative to resistance check is to simply measure the voltage on either side of the fuse. There are usually exposed contacts on the top that allow probing either side…

1 Like

Thanks! Yes it was acetic acid based. I’m a scientist, so I know the smell very well, and I like salt and vinegar chips. I am afraid I made a mistake then. I will have to redo it. I hope this ends up being a fuse because otherwise chasing these wires is a huge pain. They end up joining a bundle with two other wire groups and then disappearing into an abyss near the engine. I am I professor and have a little time until the semester starts in a few weeks, so I’m trying to save money. At least if I have to replace the TCM that’ll be a breeze.

Okay, I’m feeling dumb now. I believe this diagram indicates that the orientation is from behind the female connector, not in front looking at the pin receptacles. I believe my lettering was backwards and I was looking for battery voltage at the wrong pin. I’ll double check tomorrow, but it looks like the TCM will need to be replaced like most other owners report for this make and model.

Not uncommon mistake, happens to seasoned engineering types due to lack of convention. Really have to look closely sometimes.

Might be worth looking for a dianostic chart or procedure for that control board. It might be a bad input device vs the board. Like an output shaft sensor or eq.

I just repaired a furnace for a friend. Two repair guys looked at it and hadn’t fixed it. They both defaulted to swapping control boards. After diagnosing it, I found the problem. The power input ground wire was loose. The flame proving circuit used flame rectification and relied on accurately reading ground leakage current from the hot surface ignitor. Worked for two years after initial install with a loose ground…until one day it didn’t. :wink:

1 Like

I really appreciate all your help. Im a pharmacologist/toxicologist, so this isn’t exactly my area. I just enjoy being self sufficient (internet sufficient really). I’ll check into what you said.

Visually inspecting fuses can be misleading. It’s usually possible to probe each side of the top of the fuse with a volt meter or test light without removing the fuse. The other lead is connected to chassis ground. If you have voltage on one side you’ll have the same or nearly the same voltage on the other side if the fuse is good. If fuse is bad one side will have voltage (usually battery voltage), and the other side will have close to 0 volts. This method only works on circuits that are powered; on some fuses you’ll measure 0 volts on both sides. but if the circuit isn’t powered to the fuse, the fuse can’t be causing the problem. In any event not all circuits are powered in all modes.

1 Like

Update: First let me clarify. I have the TCM with F as the last letter in the model number. Perhaps others are protected differently vs mine (thick clear resin coat).

Okay, now the real update. When I checked the female connector to the TCM, this time with the correct orientation, pin receptacle I still had no battery power with the ignition in the on position (and with the car running). Pin J (immediately below it) had battery voltage. Pin/wire I is the AT relay wire. I checked the wire by exposing some with a needle, and still no voltage. So, back to the AT relay switch and TCM fuse in the engine fuse box. The relay switch clicks when battery voltage is applied, so I set that aside as a healthy unit. This time I pulled the 15A blue fuse for the TCM and checked for continuity with a multimeter. Voila, no continuity despite having a clean and healthy looking arc shaped metal strip in the center (no breaks). I was able to get continuity by fiddling with the metal plates/flaps on the sides of the fuse. So, I just replaced that 15A fuse, and 4 other ones, since I got a 5 pack and all the fuses have some white residue and/ or rainbow sheen indicating oxidation. So far the problem is gone, but considering the gradual reappearance of the error codes in the past I haven’t totally jumped for joy. I was too lazy to go back in and take the battery out to check the pin I voltage again, but time will tell. I think the telltale signs that this was a fuse issue were the intermittent perfect shifting, and then absolutely limp mode, and the TCM circuit board looked new one the resin was removed. I just hope the acetic acid evaporates quickly enough to avoid damage to the TCM, since I resealed with silicone sealant. The good news is acetic acid is a liquid even in pure form, and it is volatile enough that it should disappear once the silicone really dries up.

1 Like