Suzuki Aerio very high idle after cleaning MAF and putting on K&N filter on CAI

aerio

#1

ok… so some time late last year a branch or something managed to rip my filter off my cold air intake… the check engine light came on and I ignored it, simply thinking I had not tightened the gas cap.

So last week, I went to get my 2003 Suzuki Aerio SX, with 160K miles inspected, and they told me it was through a code that the mass air flow sensor was bad… Later they find out my filter is just missing… the clamp and a section of the rubber was still on the tip… but the rest of long gone.

So I have been driving, 4 or 5K miles with no filter… I buy some mass air flow sensor cleaner, spray it and now my car idles at just under 2K RPM but slowly creeps up to around 3K RPM. It drives fine, but when I pop it out of gear or hold the clutch down… it starts to go nuts.

I put a brand new K&N filter on, I didnt add any oil to it as it didnt say it needed any and it wasn’t dry, but not soaked either.

Now when I went to remove my Mass Airflow Sensor, I did remove a couple other parts first by mistake. I fiddled with the temperature sensor inside my cold air intake, but I couldnt get it out due to the rubber ring around it holding it in and sealing it. I also removed the Fuel Injection Manifold Pressure Sensor but I am pretty sure I put it back on fine. and I did remove the Throttle Position Sensor… so maybe thats my issue?

what should I do to troubleshoot it?

I sprayed wd40 on the throttle above the engine, not sure if it was it or not but my engine was idling at a lower 1800 rmp for a while, still high but not as bad, I took it for a ride around the block and when I got back it was at 3K again, it did run at a steady 20 mph in second gear with my foot off the gass completely.


#2
  1. get rid of the K&N CAI and put the old parts back on. These things cause more problems than any aftermarket kit I can think of. They’re a sham.
  2. replace the MAF; it’s likely wrecked from oil contamination.
  3. double check the manifold pressure sensor to be sure it’s properly seated.
    The WD40 probably did no harm. But don’t go changing parts and/or spraying stuff into your induction system again until you learn what you’re doing. No disrespect intended.

Post the results. I’ll bet your engine will run fine.


#3

Good advice above. If the tps isn’t working there should be an obd II code stored for that. So check the codes. Just b/c the cel ins’t on doesn’t imply there are no stored codes or pending codes. If the tps isn’t working that could indeed cause an idle rpm problem.

I had a fast idle problem on my Corolla one time and very difficult to diagnose the cause. It turned out to be a combination of a faulty engine coolant thermostat that wasn’t allowing the coolant to heat up to the proper temperature, and a problematic throttle-body idle air control gadget. My solution was to just disable that idle air control gadget. The downside is I have to press my foot on the gas pedal a little for a minute or two to prevent stalling on cold starts on a few very cold mornings in the winter. But it isn’t much of a burden.

You definitely need to get the high idle problem fixed, as it will result in transmission/clutch/drive-train problems.


#4

SO I did some research and the throttle position sensor has to be put on a very specific way, and thats my problem, the screws have a slider they go into, to adjust it., and i didnt know that and I just put it at its highest settings. as for putting stock parts on, they are long gone. I have had the cold air intake for over a decade now. I am going to properly adjust the position using a volt meter and ill post my results.

theres a lever thats attached to the throttle wire, thats what we sprayed with WD40, we thought maybe the lever might be sticking. Yeah I definitely do not know enough.

But thank you both for the advice, I didnt do my homework when I upgraded to the CAI, but I was just a kid with a brand new car back then lol…



#5

I looked up my repair notes, and my Corolla’s high idle problem was also partially caused by the tps being out of adjustment. It was sort of a fiddly-job to get it adjusted, but after a bit of my fingers getting pinched, my noggin’ hitting the underside of the hood, and associated cussing I finally go it to match up with the spec.


#6

Thanks George, I bought a Innova 3020b… really isnt enough, anyways it gave me a P0122, M, F, CC, OH lit up and C, EV, O and E were blinking…

I am trying to find an actual code scanner that does something other than tell me the obvious, but finding one that will tell me actual RPM, voltage, pressure and the like seems to be next to impossible.

I just bought the Innova 3100 but havent opened it and I think im going to return it… its been really frustrating. I really regret not learning cars as a kid.


#7

Try typing “scan tool” into the search box above, folks have asked this same question here before, so you may find a recommendation for a good one in a prior thread. Some posters here have said they get the best results for real time mode data using a scan tool gadget/software/ap which hooks into either a laptop computer or a cell phone.


#8

perhaps the tps itself may be bad

I’m saying this because the code clearly points to a problem detected in the tps circuit. And it sounds like you messed around with the tps, but never actually replaced it

Have you adjusted it the factory way, which usually involves a digital multimeter?

Any Chilton or Haynes manual should also have the procedure listed


#9

Thanks George, yeah I was clearly using the wrong words to try and find an existing discussion. I was using code reader and the topic most relevant was from 2010.

And to db4690, no I havent replaced anything a side from buy a new filter. I did buy a IAC but have yet to install it. I know its totally possible that I damaged the TPS, in Aerios it is adjusted by slightly loosening the screws that hold it to the throttle body and rotating it a little bit. I did also so in the Service Manual that inside the throttle body there is something I can tighten.

Right now I just want to get my hands on actual data, I wanna see whats off and by how much. Otherwise all I can do is replace parts, but if Im not installing them correctly then really Im just wasting money.

Im going to find a good scan tool and go from there.


#10

So I replaced my TPS, MAP, the high idle has been solved, but I still have the P0122, and I did get a scanner and my ECM keeps saying it’s getting 0% from my TPS. I checked the voltage from the ECM to TPS at the plug and its correct, so maybe the ground isn’t connecting?

I screwed in the MAP as tight as I can. It is kinda nasty in the hole it sits in.

But also, the TPS has a hook, or just a part that stick out that catches on the throttle that runs through the throttle body, how can I tell that I have the TPS positioned correctly that it is catching?

I guess I can supply power directly to the TPS and check the voltage? Now I know each line should have max 6Vs, so I need to just split the wire from the battery right?

Only issues I am having now, is the slight drop in RPM right as I press on the accelerator, and it doesnt instantly drop to idle RPM when I put it in neutral, it goes down to about 1200 and when the car comes to a complete stop it goes to 850. Could that be the throttle sticking?


#11

Ok so update, so I ran a wire from the ECM/PCM connector to the TPS and I had continuity on all 3.

So I think my computer is bad, either cold solder, stratched trace or connector issue.

So now I’m trying to find a used one. I know I have to match the same, year, MT and non AWD.

Anything I need to know or look out for?


#12

The TPS is usually just a variable resistor. So it would have a constant voltage as one input, a ground as the other, and the third is an output which would vary between ground (0 volts) and the constant voltage (often 5 volts) depending on the throttle position. Does that output signal on your current tps vary with the throttle position (how much you press on the gas pedal)? It has to be connected and powered up for this to work. But the engine doesn’t necessarily need to be running, depends on how the ECM works.

I say the above b/c I doubt replacing the ECM is going to fix this problem.


#13

Yes my TPS is like that, a dial resistor. I checked the old one and yes the voltage changes on my multimeter, it goes up to.
I gave it power and ran my voltmeter on the middle wire and it responded exactly as I figured it should, and when not touched at all it red 0.

I unplugged the installed one and plugged in my old one and when I moved it, the car didnt react.

So it has to be a bad connector or the ECM/PCM, right?


#14

The way to tell if the tps is attached to the throttle correctly is to measure the voltage from it as you press on the gas pedal. You’ll have to refer to the correct procedure for your car, it varies on how exactly this test is conducted. At any rate, the voltage from the tps should change with the gas pedal position, usually from near 0 volts with no gas pedal applied, to close to 5 volts with the gas pedal to the floor.

If the voltage is varying correctly but the ECM says it isn’t, could be the ECM, but could also be a broken wire or bad connection somewhere between the ECM and TPS.