CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

Subaru Impreza 08 -- won't start, computer issues?

My 2008 Subaru Impreza was in my driveway, not running but the radio was on while I was cleaning it out. After maybe 30 minutes the radio abruptly shut itself off. I removed the keys, reinserted, still no radio. Tried starting the car and absolutely no starter noise; dash lights & dials still worked, dome light still worked, electric windows still worked. The trunk (electronic latch) did not. Tried a jump start, no luck. At some point I notice a relay ticking regularly (slightly faster than once per second, I’d say). It only seems to be ticking when the key is not in the ignition. If I try locking/unlocking with the remote, I get a weird squeak noise instead of the standard horn beep. Later I try starting it up again, & this time dials go on, but then go back down really jerkily, and the dash lights flicker.



Crazy computer issue? Security system gone wild? Any ideas before I call up the dealer & have them tow this thing away? (It still has 1 month left on the warranty.)

If you cannot jump-start it, let the dealer look at it under warranty. Anything more invasive than that not done by the dealer may compromise the warranty. This sounds like a module somewhere went crap. This should be covered by the warranty.

It sounds like the battery ran down from having the radio on. If the battery was getting kind of weak, 30 minutes with the radio and dome light could kill it. When battery voltage gets too low on a modern vehicle, it can temporarily scramble the brains of electronic modules, causing all kinds of weird behavior.

Are you sure you were jumping it right? Do you have a battery charger? If you can get a battery charger, try charging the battery, then see if it behaves better. If you have a voltmeter, check the battery voltage. It should be over 12V with the car off and no accessories running.

If charging the battery doesn’t remedy it, try disconnecting the negative battery terminal for 30 minutes, then reconnecting it and see if that helps. This may reset everything. If it still is acting weird and no fuses are blown, it sounds like it’s time to invoke that warranty while you still have it.