RPM's fluctuate when shifting to "D" or "R" position

I started this discussion in the ‘General’ topic, but I wasn’t that informative about my issue so I’m gonna delete that discussion and try to be more informative here.

Hyundai Elantra 2009
147,531 Miles
Engine: 2.0L
4 Door, Sedan


When I start the car with cold engine (85-95 F ambient temperature), the RPM’s act normal when idle, but as soon as I put the car in “D” or “R”, the RPM’s start to fluctuate, going up and down. between 600 and 400 RPM’s. As soon as I press the gas pedal, the problem goes away.

This happens randomly, but it’s becoming more and more common for it to happen. Also, it is not common, but sometimes it happens when I am going at speeds between 45 to 65 MPH’s and I stop at the traffic light. The RPM’s start to fluctuate while at idle.

If I start the car with the engine warm, it doesn’t happen. The RPM’s act normal at idle and when I put the car in “R” or “P” too.

[ No Check Engine Light ]


Things I did to troubleshoot the problem:

  • Did a vacuum pressure test at the intake. It’s OK.
  • Did a vacuum pressure test at the Brake Booster. It’s OK.
  • Did a leak test with a smoke machine with open throttle. It’s OK.
  • Did a complete OBD2 Scan to view the Live Data Stream. Below you’ll see the results. Don’t know if they are at a normal range or not. But take a look at the FUEL SYSTEM BANK 1 Test 71 and the LONG and SHORT Trims.


I bought this car like a year ago and did a complete tune up.

  • New Fuel Pump & Filter
  • New Iridium Spark plugs
  • New Coil wires
  • New Ignition Coil
  • New Alternator
  • New Mass Air Flow (MAF) Sensor
  • New Cabin and Engine Air Filter
  • New Canister Purge Valve
  • New Idle Air Control Valve
  • New Coolant Temperature Sensor
  • New Oxygen Sensors (BANK 1 & BANK 2)
  • New Transmission Shift Solenoid
  • New Ignition Switch
  • New PCV Valve
  • New Brake Hoses
  • New Calippers
  • New Brake Pads
  • New Rotors

Also I did some repairs and cleaning:

  • Cleaned the Throttle Position Sensor (TPS)
  • Cleaned the Throttle Bodie
  • Cleaned all four Injectors
  • Changed Engine Oil and Filter
  • Changed Transmission Oil and Filter
  • Installed a new Top Valve Gasket do to an engine oil leak.


Live DataStream with OBD2 Scanner (Car at IDLE with Engine at normal working temperature/warm)

  • FUELSYS2: —
  • LOAD_PCT: 22.4%
  • ECT: 80 ºC / 176 F
  • SHRFT1: -8.6% (did a test at 855 RPM’s and sometimes goes to -17.2%)
  • LONGFT1: 0.0%
  • RPM: 669/min
  • VSS: 0 km/h
  • SPARKADV: 4.5º
  • IAT: 39 ºC
  • MAF 3.24 g/s
  • TP 4.3%
  • O2S12: 0.760v
  • SHRTFT12: 99.2%
  • RUNTM: 673 secs.
  • MIL_DIST: 0 km
  • LAMBDA11: 0.996
  • O2S11: 2.020 v
  • EVAP_PCT: 0.0%
  • FLI: 93.7%
  • WARM_UPS: 139
  • CLR_DIST: 3909 km
  • VP: 162.3 Pa
  • BARO: 98 kPa
  • CATEMP11: 533 ºC
  • CATEMP12: 533 ºC
  • VPWR: 14.17 v
  • LOAD_ABS: 35.7%
  • LAMBDA: 0.996
  • TP_R: 0.0%
  • AAT: 27 ºC

Also checked the status of some sensors:

  • O2 Sensors passed the test.

  • All Catalyst Monitor Test: Passed.

  • EVAP Monitor Test: Passed.

  • Purge Flow Monitor: Passed

  • No Misfire’s on neither cylinders where reported.

  • Fuel System Bank 1: TEST 70 did passed the test and TEST 71 did passed the test at first. But after doing a second test it failed. Here’s the data:

Component ID: $71
Limit Type: Min & Max
Value: 62.6s
Min: 0.0s
Max: 60.0s
Status: Fail


I hope that all this info is helpful for you guys, since I already went to 3 mechanics and they don’t know where to begin checking since their guesses where parts that I already bought OEM new and have less than one year of use.

Thanks in advanced!

It sounds like the Idle Air Control valve is hunting for the proper idle speed when the vehicle is shifted into gear.


1 Like

Do you hear the rpm change? Had a bad gauge but no engine problem.

Agree with @Tester idle air control valve can’t hold a steady idle and needs replacing or the passage needs a good clean

When I bought this car, had this same problem and one of the reasons I installed a new one of these, was because some one else suggested it, but the problem didn’t go away :’( Also, I want to add that the one I bough it wasn’t OEM. I bought it on eBay. Maybe it’s not that good… (already tried cleaning it)

And yes. I can hear the engine struggling when the RPM’s goes down to 400. It feels like it’s stalling and some times wants to die. But it always stay running until I hit the gas and everything goes away and return to normal.

These look within the normal range

But this one, not sure how to interpret what parameter that is measuring. A 99% fuel trim is definitely not normal.

My guess is either a problem with a wandering throttle position, or a problem with the fuel injection system. Does you car use a separate fuel pressure regulator located at the end of the fuel rail, with a vacuum hose attachment to the intake manifold? If so, take a look inside that vacuum hose. Any signs of gasoline? If so, replace the fuel pressure regulator.

A fuel trim reading of 99.2% on sensor 2 is normal on some cars. Most ECU’s don’t use fuel trim from post cat sensors to adjust fuel. So instead of reporting actual fuel trims they will report either a 99.2% or N\A.

1 Like

I doubt about the Throttle Position Sensor (TPS), cause I did a test with the multimeter and it did showed the correct values according the repair and maintenance manual. Also, I did clean that part too just to be sure.

About your question… no. This car doesn’t have a separate fuel pressure regulator at the end of the rail. It only have one attached to the fuel pump and filter. Also, it’s brand new.

So today I went to the auto part looking for an Idle Air Control Valve (IAC), but they want $250 for an OEM and $55 for a Generic one… just like the one I bought from eBay for $12. I decided to take it out, clean it with carburetor cleaner and soaked it in WD-40 Specialist. Hope this last step prevent it to stick. Lets see what happens…

Do you have drive by wire?

Yes. The throttle opens with wire tension.

Drive-by-wire means the vehicle has an electronic throttle body.

Your vehicle doesn’t.


Oh… sorry. I wasn’t sure what that meant. That’s why I said it works with tension wire. (English is not my primary language)

My 92 Corolla developed an idle speed problem like that some years ago. 92 Corolla has cable operated throttle, and the idle air control function is built into throttle body, coolant flows through that part which opens/closes an air path as a function of coolant temperature in similar way to how the main coolant thermostat works, wax volume vs temperature. I traced this down to a faulty idle air control valve. The way I proved that was the problem was to temporarily disable it by blocking off its airflow. Once that mod was in place, the wandering idle rpm vanished. My final solution was just to keep it configured with it disabled. This causes the engine to have a tendency to stall at idle (or stop-signs) when it is really cold outside, and the engine hasn’t yet had a chance to warm up. The upside of living in San Jose, its rarely cold enough outside to cause that problem. And it only takes 3-4 minutes before the engine is warm enough to overcome the problem.

Wandering idle rpm seems most likely caused by one of these

  • any path allowing uneven air flow of any type into the engine’s intake manifold ; e.g. intake manifold gasket leak, pcv system, leaking vacuum operated device (such as brake booster) etc
  • unsteady fuel delivery to the cylinder or intake manifold, most likely caused by varying fuel pressure to the injectors
  • varying obstruction(s) in exhaust path, or air leaking into the exhaust system
  • computer adjusting for time varying faulty sensor reading(s); e.g. coolant temp sensor, ambient air temp sensor, mass airflow sensor, map sensor etc (note: problem could be an electrical connection problem rather than the sensor)

Try to figure out a way to eliminate those as possibilities one by one by temporarily disabling parts of the function etc, similar to how I disabled the idle air control function.

I had a similar problem on my 50 year old Ford truck I’ll relate for completeness. I just recently solved this. The cause was a problem with the carburetor. The airspace above the fuel bowl was getting pressurized causing more or less fuel to flow into the engine depending on the pressure. (The analogy for a fuel injected engine would be unsteady fuel pressure.) Caused b/c the vent was blocked. Once the vent was unblocked, problem disappeared.

I would guess idle air control valve or MAF sensor. I’m not sure how to test them, though. I have had better luck with OEM sensors pulled off of scrap vehicles than I have had with the cheaper aftermarket sensors.

1 Like

It is the stingy person who spends the most.

So after a month, the problem has getting worse. Now the car is stalling at idle, it’s consuming more fuel than ever, it doesn’t have the same force and it’s shaking. Also there’s a black liquid coming out from the muffler.

I’m getting check engine codes for the first time.

  • P0301 which is a Misfire on Cylinder 1.
  • P2231 - O2 Sensor Shorted to Heater Bank 1

So I swap the O2 sensor with the old one I still have around.
Installed a new spark plug in cylinder 1 and swap the spark plug wires. I want to mention that the spark plug was a bit soaked in gasoline and with black residues (these are iridium NGK spark plugs with 5,000 miles of use).

Nothing happened. I was getting the same codes again. So I took out the Fuel Injector Rail to clean all the injectors and the did nothing. But I noticed that the rail in fact have a Pressure Regulator, although I did a search and Hyundai called it “Damper Pulsation” (Part #35301-23900). Anyway… I ordered an OEM one from the states since no one have it available in stores in Puerto Rico. I will keep you guys updated.

BTW, The Pressure Regulator doesn’t have a vacuum line. I just connects to the fuel line and thats all.

Given the configuration, I doubt that part’s purpose is to regulate the fuel pressure. In any event a fuel regulation device wouldn’t usually be replaced unless a fuel pressure test showed the fuel pressure was incorrect. Has a fuel pressure test been done? If not, suggest to do that first.

I think some important clues have turned up though. The shorted O2 sensor code doesn’t necessarily imply the sensor is faulty. In your case seems likely to be a short in the wiring harness going between the sensor and the ecm. Your O2 sensor is the heated type. That means there’s a resistance heater along with the O2 sensor. The heater is there to allow the engine to go into close loop status sooner after starting the engine, which reduces emissions. The short is probably between one of the O2 sensor wires and one of the heater wires. If you know how to use a DVM, you could probe the voltage on all four of those wires, report back here what you discover. Note that if that’s the actual short, it could have also possibly damaged the ecm.

It’s going to be necessary to resolve what’s causing the gas load in cylinder number 1. Possibilities include

  • O2 sensor problem (above)
  • Faulty injector
  • Faulty injector pulse signal.

Those have to be eliminated one by one. The last one is probably the easiest, compare each injector to the others using a noid light.

With this sort of problem a shop would probably do a fuel trim test. That would provide an important clue. If you can get one done, report the results here.

One more piece of bad news however: The misfire may have damaged your cat. It may be plugged and needing to be replaced after the misfire problem is resolved. It’s also possible the plugged cat is causing the misfire.

Thanks for your reply and willing to help :slight_smile:

So I decided to first check the connector with the DMV. I followed the service manual which says to do 3 different test. First measuring the voltage between terminal 6 and chasis ground to check the Heater Control Circuit. Specification is 4.5v and I got 4.4v which is in the range. So it’s good.

Then I had to test the Heater Power Circuit between terminal 5 and chasis ground. Specification is “Battery Voltage” and indeed… it was 12.2 v which is also good.

The last test was a bit awkward. So I needed to measure the resistance between terminal 6 and 1,2,3,4,5 and the specification is “Infinite”. When I put the red probe in terminal 6 and the black probe on 1,2,3,4,5… it stays in zero ohms. I don’t know if there’s no resistance, or the scale exceeds my DMV specifications which I doubt. its an auto range DMV.

So I decided to swap the probes and I put the black one in terminal 6 and the red one in 1,2,3,4,5. Now I got a reading of 14.7 M Ohms, and between 6 and 5 I got 3.1 M ohms.

What do you think about these readings? I believe resistance is bi-directional, right?

Are you certain the ignition was set to “off” when you did those ohm measurements? And the engine was cold, hadn’t been run in several hours? Zero ohms is definitely wrong, & it could mean there was current flowing in one of those wires ,which will confuse the ohm meter.

Suggest to repeat the ohm measurements. Do this after the engine hasn’t been run overnight, and make sure the ignition key is set to “off”. If you still get those zero ohm measurement, try it again with the battery negative disconnected, and while the connector remains disconnected, measure the resistance between the same pins, only on the sensor side. Note that current could flow from the O2 sensor if it was warm; it acts sort of like a battery that gets its electrical energy from heat.

Also, the zero ohms measurement you got may mean there was current flowing in the circuit. That could possibly damage the ohm meter, so do an independent test on a known resistance w/ the meter on the same scale setting so you know you are getting accurate measurements.

If you did the test correctly however, then it appears there’s a problem in the wire harness between the O2 sensor and the computer. Or the computer is faulty.

This is how I tested the connector. Probes in the terminals. These are the ones that connects to the ECM, while the oxygen sensor remains disconnected.

Also, the car is cold. Hasn’t been turned ON in days. When I did the test, ignition was OFF.