Replaced ignition coil now zetec runs horribly with terrible gas mileage

My 2002 Ford Focus SE with the Zetec engine had been running perfectly (fantastically) for the past ten months. But after changing the ignition coil (to address another problem), the car started running rough and using tons of gas (14 mpg). The car often smells like gas. This should not have happened after simply changing the coil. I tried a second new coil (a Motorcraft part this time around) with no change. I then spliced in a new connector (to the coil) with no change. I also replaced the plugs and plug wires with no change. No error codes are being thrown, but I’ve tried resetting the ECM with the trick of disconnecting the battery and attaching a lead between the positive and negative cables. No change. Can anyone shine some light on my problem? I cannot continue to replace parts that were working fine up until the coil replacement. This is strangely related to the coil replacement, but I admittedly do not know what’s going on. Any thoughts will be appreciated.

NOTE: The reason I replaced the coil when the car was running perfectly was to remedy a cold start issue. I now have to park the car outside, and when the temperature drops below, say, 20 degrees, the car will start, run for five seconds, then stop. I can start it again and it will run for five more seconds and then stop. Sometimes, if I keep the RPMs high and keep the engine running until it gets hot, it will then run on its own, but I usually have to wait for the outside temp to warm, then the car runs fine. But this is not the issue I want to focus on (since warm weather has arrived). I mention it only to explain why I replaced the coil to begin with.

A bad crankshaft position sensor can cause all those symptoms.


What happens if you reinstall the old coil one back in?

I wish I could do just that. The coil I took out was just inside the one-year warranty, so I (like a dummy) exchanged it for a new one. When problems showed up, I had the same thought as you and kicked myself for letting the coil out of my possession. This is why I then paid $10 more for a Motorcraft coil, thinking that a higher quality part would solve my issues.

Where is the coil located on your car? A small gadget inside the distributor? Mounted on the firewall? I’m presuming your ignition system is configured as electronic sensors to detect crankshaft/camshaft rotation, electronic high voltage igniter, computer controlled, to generate the sparks, mechanical distributor for divvying up the sparks to the various plugs.

If I had to guess, it sounds like a grounding problem has developed. Double check the grounds you had to remove to install the new coils.

Please keep us up to date on this. Sure would like to know what was the fix would be.

Here a link to a video that will answer all your questions. I will check the grounds. Thanks for taking time to read my post.

Didn’t watch the vdo, but I see from the photo you have a coil (almost) on plug arrangement there. There may be a ground connection where the part mates to wherever it fits, bolts through those holes. there’s also probably a resistance test you could make at the connector pins, if you knew what the resistances were supposed to be. A problem could have developed (just b/c they got flexed in the process) with the high voltage wires to the plugs too. Any chance the wires got put on the wrong plug? That will definitely make an engine run poorly. Ask me how I know … lol …

Ignition coil for a 2002 Focus with the Zetec engine.


There’s no individual coil right on top of the spark plug, but no distributor either, right?

I’m thinking this might not have anything to do with the coil at all but the original problem just happened to get worse after the coil was replaced…possibly. The gas smell made me think fuel pressure regulator or pressure sensor, but that should set a check engine light. Not sure if you can “test” a fuel pressure sensor like you can a regulator, and I wouldn’t want to just throw parts at it.

You unplugged 4 plug wires. The odds of mixing up 4 wires is pretty slim. So, I would say a bad wire with cracked insulation? Lousy plugs? More likely the wire harness that plugs into coil.

But why would replacing the coil take out the crankshaft sensor? And why would the car continue to start easily, run, but never generate an error code. An interesting thought, though!

The newer Focus models have coils at each cylinder but not my old thing.

Thanks for replying to my post!

You know, you might be on to something here. I at one time thought of the pressure sensor as the problem but dismissed the idea because of the price of the part ($120-150) and because I assumed the original problem was only associated with cold weather. The two problems very likely could be related. Let me do some checking and troubleshooting and get back to you (and everyone who has been so helpful).

1 Like

I never said changing the coil would take out the crank sensor.

But don’t chase your tail thinking something you did caused the problem.

Because sometimes other engine control components can fail that has nothing to do with the repair.

Why doesn’t it generate an engine code?

If you would have read the article, it explains it.

Check Engine Light

A failing or failed crankshaft position sensor may cause the check engine light on your dashboard to come on. A diagnostic scan tool will show a code between P0335 and P0338. The check engine light doesn’t always come on, though, so you could be experiencing any of the above symptoms for some time before you see the warning light.


Maybe the best thing is to back up, take a deep breath, and make double sure that a few plug wires are not crossed up.
There’s also the possibility if the wires are 20 year old originals and took a bit of tugging to remove that one or more may be damaged.

The poor running cold could also point to a vacuum leak.

what was the outcome this this?

I’m still struggling with the problem. Because no diagnostic codes are being generated, I’ve become a parts-changer. I replaced the fuel regulator with no change, then the fuel pressure sensor with no change. Yesterday I replaced the throttle body and TPS with brand new parts and did note some change: better acceleration and throttle response at low speeds. But today, after letting engine warm up before heading to work, the car was running poorly again. I may see what happens in the days to come, then run through the idle relearn procedure again. I’m starting to wonder if the PCM/ECM is bad, not sorting through all the input data correctly. I’m more or less at a loss. If I can get the gas mileage to improve some, I’ll just live with the poor performance.

wow you did a lot. Sounds like you are on the right track. Have you removed the battery cable so you can reset the PCM/ECM values?