Radiator Fan Refuses to run!

Already replaced the Relay and the temperature sensor; checked fuses and the fuse link; and jumped the relay output to see that power wiring is OK and still connected.

But still doesn’t run. Have not checked the two control wires back to the computer yet. The temperture guage on the dash looks like it is reading OK. I expected that by the time the thermostat opens the fan should start. Also expected the fan to run if the A/C compressor was on.

No luck!

Chevrolet Corsica 1993.

I would think if it was the computer itself, the car would not run at all!

Any clues?

Did you try running battery voltage to the fan motor to make sure it works?


You can’t rule out the ECM, it controls the ground side of the circuit. Plus it could be the problem and the car can still run.

I bought a used car and the fan would run constantly whenever the engine was on. It turned out to be the computer. Note that this is the opposite of your condition, the always-on fan seems to be the default for safety. Therefore I am reluctant to suspect the computer.

Go with Tester’s advice about seeing if you can get the fan to run if given a direct +12v plus a good ground. Maybe you have a burned out fan motor.

I thought I stated it runs fine when jumping the relay output; thus it is a control wiring issue, not a fan problem nor a power wiring problem. The voltage is also fine. The control circuit fuse is also fine.

So, how do I check the ECM, and if that is the problem, is there a simple fix, or is it necessary to buy a new ECM?

Someone suggested just wiring the relay control to the ignition, but then the fan wouldn’t run after the ignition is turned off.

The fan was stuck on previously, but the radiator leaked, and the fan motor eventually burned out. After replacing the radiator and the fan, have not been able to get it to run without bypassing the relay. The relay is new and functions fine.

No you didn’t. Look at your original post.


You are correct; I was going to post an addendum that when I jumped the output of the relay, it ran fine.

Still no clue, unless it is the ECM or wiring to the relay from the ECM, OR possibly there is another temperature sensor/switch in the radiator connected to the ECM that is not indicated in the Haynes manual?

The parts dealer indicates there is only one temperture sensor; none in the radiator. There are only two control wires from the fan control relay; one goes to the fuse #9 (20 amps)- hot when ignition is on, bulb test, or? I need to check that wire.

The other, goes to the “power control module” behind the glove box, to connect the wire to ground when the fan needs to run. I need to check this wire, and also whether the power control module is grounded.

A repair shop says $89 for a “diagnostics”, and $150 to install a power control module. But the only $79 for an ecconomy PCM, and there are only a couple screws holding the glove box in, and the PCM just unplugs.

But does the PCM need any “programing” when installed?

The Pink wire with black stripe at the relay does have 12 volt control power when the ignition is on.

The Green wire with white stripe at the relay does have continuity to the connector at the PCM.

The part store looked up the PCM incorrectly; they don’t have access to a PCM to sell me, and thus I don’t know the price. There is a computer/memory plug-in something inside the box; I don’t have any clue of replacement requirements nor programing.

I still can’t figure out whether the part needs replacement or not, or if it is a programing issue or a grounding issue.