P1273 code on Nissan 2004 Altima

nissan
altima

#1

Hi… I have a 2004 Nissan Altima 2.5S with 165,000 miles on it. Two months back, my service engine light was on with Error Code P0420 – Catalytic System Efficiency Below Threshold Bank 1
I went to a mechanic, he put in a spacer/piper such that the code doesn’t come again. He also replaced the A/F sensor (upstream O2 sensor).
Within 2 hours of replacing, two more Error codes came up (see below) and the I could feel the car vibrating/shaking everytime I started my car and also ran at slow speeds.
Code P0037 - HO2S Heater Control Circuit Bank 1 Sensor 2
Code P0138 - O2 Sensor Circuit High Voltage Bank 1 Sensor 2

The mechanic now replacted the downstream O2 Sesnor. Again, within 2 hours of replacing, another code came up Error Code P1273.

This time the mechanic thought that the upstream O2 sensor which he replaced earlier may be faulty and he replaced the A/F sensor (upstream O2 sensor) again.

However, the same error code came up again P1273.

Can you please advise what to do?


#2

Did the mechanic perform a self-learn procedure after replacing the air/fuel sensor?

https://www.nissanhelp.com/diy/altima/projects/nissan_altima_clear_self_learning.php

Tester


#3

He just cleared all the codes. He didn’t perform the instructions in the link.


#4

You have 2 discussions, concerning the same car and the same problems

Please consolidate them

I gave you advice in the other discussion


#5

This is GREAT! The instructions in the link provided here by “Tester” and “db4690” works! I had replaced the spark plugs, upstream and downstream O2 sensors! But the P0420 would not disappear…finally followed the “self-learn” procedure and it worked! Thanks a bunch.

However…the TID:$01 CID:$01 Rich to lean sensor threshold still FAILS! Any suggestions?

NOTE: This was for a Nissan Altima 2003 2.5S with 120,000 miles


#6

Thank you for getting back and letting us know what was done, and the results! That’s how we all learn.