Musty Smell in 2006 Rav4

rav4
airconditioning

#1

Hi, I’ve had a musty smell in my 2006 Rav4 since the early days. I should have taken it in right away for service but I bought it in the winter and the smell didn’t appear until the next summer. When I first took it in, they sprayed it 2 or 3 times with frigi-fresh and the smell kept coming back. They eventually replaced the evaporator and 2 months later the smell is back. Now they want to start spraying again and I want this solved within the next few thousand miles before my warranty expires!



The Toyota dealership service department in my area is now telling me that ALL toyotas have these problems but my friends with Toyotas don’t have any issues and I don’t see a trend through my online research.



Is there a known problem with Toyotas and musty smells, is frigi-fresh really THE solution for this problem in such a new car, etc. Any advice is appreciated! Thanks




#2

Now they want to start spraying again and I want this solved within the next few thousand miles before my warranty expires!

I hope you have records of those visits to the dealer. If not try to get copies from them. Ask for all service records. The new car warranty does not expire on on going problems. Just make sure you keep after them and keep bringing it in and keep records. Also give a read at //www.jdpower.com/cc/auto/bbb/lemon_law.jsp or http://www.lemonlawamerica.com/


#3

Ask your dealer about a “afterblow” kit. It keeps the fan on after AC shutdown. GM has had sucess with this concern. This condition is nothing special to Toyota. Do a search on this forum for “AC odors” you will find lots of comments.


#4

You are not alone. A lot of people complain about this. I am very susceptible to mold allergies so I have done some research. I think you are on the right track by looking to clean. Most people are looking for a magic spray that will fix the problem and lots of people suggest this approach – Lysol or similar stuff sprayed into the AC system with the blower running and the windows open. This may work for a time, but it is probably only a temporary solution. It will kill existing bacteria and fungi, but they will start to regrow as soon as the culture medium (crap) in your AC system is reinnoculated (immediately).

First the simple solutions. Check to be sure that your AC drain is not clogged. Try not to park under trees and keep the air intake grill/screen free of debris. Another simple thing to do is when you park the car be sure to leave your HVAC system in any position BUT “off”, “max” or “recirc”. Some owners’ manuals specify this to let air circulate through the system. Try turning the temp control to full hot after parking before you shut the car off. This, in theory might circulate hot dry air from the cabin back through the evap coil by convection. Note well the “in theory”. I have not tested this theory, but it seemed to help me a little. If you live where it is not too uncomfortable, turn the AC off some time before you park, it might help dry the system out. Note that running it right before parking with the heat on is not likely to help since the heater is AFTER the AC coil in any car I have looked at.

You might need to clean out your system and keep it from getting full of leaves again. Some models are easier than others to get to. Often the blower motor can be pulled out or the blower motor resistor assembly can be removed from the plenum to gain access to the AC evaporator coil. With some cars these elements are easy to get to but others are very difficult. If you can get at the coil you can spray some detergent in there. I have also used 10% bleach after the detergents. If you use the latter I would not let it sit for more than a few minutes before rinsing extensively because you could corrode aluminum parts.

There are lots of cleaners and coatings for auto and home AC systems. Some Foaming or other cleaners rumored to be available for residential use should work. AirSept makes some coatings for Auto use. They require removal of the coil which will cost you time or money. I have not tried them.

Some car models seem prone to this problem. It must have something to do with how well the systems dry out after shut-off and how much crud collects in the “coil” (Now, I believe, many manufacturers use flat-plate heat exchangers.) I hope that the answer to the problem will be effective filters to keep the food away from the microbes that like to grow in moist, dark places.

I have spent a lot of time on this problem and I’ve had some generous help from people on web fora. Getting information about the auto manufacturers’ equipment was not easy. It seems that not many people out in the trenches (auto techs), even the factory-trained ones, know about them.

Despite the attempts at secrecy, I have found out how some of the manufacturers remedies work. Some of this information is dated and some of this stuff might no longer be available. Ford has or had a kit and a TSB (02-11-7 ,JUN 02, A/C System - Musty/Mildew Odors) . There is an “afterblow” or “purge” module and two wire kits to make it fit their various models. The price would be about $200 total depending on what wiring harness is needed. It runs the blower on high for a couple of minutes some time after the AC and car are shut off. The delay is important because no cold surface is going to dry with hot, moist air blowing over it. It also prevents operation at convenience store stops. I have also read recently that Ford no longer offers this stuff because of run-down battery problems. I don’t recall where I read this and I have not checked the facts.

Saturn has a kit for about $125 (delayed blower motor controller: 21031158). It seemed to be adaptable to any car. I was told that it runs the blower for 5 minutes after the car is turned off for 50 minutes to allow the coil to warm up.

Airsept probably still has a web site. They also make an afterblow module that is universal. The cost was about $300 to AC techs, I believe. It is costly, but it should work better than the others. Look a the site for the features. It starts a pulse cycle after giving some time for evap to warm. The pulse operation is supposed to squeeze the most out of your battery’s electrons by allowing the evap box warm up a little between the drying (cooling) pulses. It also has battery protection. It sounds good to me.

Airsept also makes cleaners and coatings to prevent microbe growth. These should also work. For most, however, you need to take the system apart to coat them. Note that there are foaming cleaners available for home HVAC. They should also work. Note that DSS (Dirty Socks Syndrome) is an issue with home units as well.

I live in a very hot/humid place. I pulled the blower motor from my car, cleaned and disinfected the evap. Fortunately one side is is readily accessible in my car. The evap looked sparkling clean, before I started so the microbe growth might be somewhere else in the plenum. I decided that I could make my own afterblow module with a little time and a soldering iron. I saved a lot of money and got great performance.

I went through several designs and decided that, in my climate, on most days when the humidity is high, I would need an auxiliary battery to dry the evaporator out with the HVAC blower in combination with systems like the commercial ones. I decided to reverse the afterblow. This blows cool, dry cabin air past the heater core and the evap. I made it with a small, plastic squirrel-cage blower, an inexpensive “multimode” timer kit and a couple of automotive relays. I plumbed the blower in to the passenger foot well heater outlet (not as easy as it sounds). I have a seasonal change-over of removing this and taking the duct tape off the other 3 heater outlets.

During AC season (10-12 month) I have to remember to put the system in the “floor” mode and turn the heater to high as I park. I have the timer triggered on the AC control so it activates if the AC has been on and runs the little blower for 2 h. I have a reset button and an on/off switch stuck behind the lighter in the ashtray. All the equipment is tucked up behind the dash. I have also added a little $20 pneumatic valve that opens the dash vent ducts when the blower stops to allow better circulation in case there is any residual moisture in there.

My solution is obviously not a universal solution, but it works for me and was inexpensive. My total costs were higher because I had a lot of false starts, but to repeat it would probably only cost about $30 excluding the valve. I did spend a lot of time on it.

The “Multimode Timer” kit is available at several mail/wwweb places. A couple:
http://www…r_k141.htm

http://www…ck1614.htm

Manual at:
http://www…ck1614.pdf


#5

clean the drain, remove the cabin filter, spray an a/c disinfectant ( i never heard of frigi-fresh) into the opening the the blower on high. hope this works.

i have 2 fords the had the musty/mold odor so bad it gave me headaches. i did this last year on both and all is good now.