Motor swap need help

gmc
yukon
computers
sparkplugs

#1

I am working on an engine swap in a 95 yukon with a 5.7, originally TBI. Installed a Vortec 5.7 out of a 96 truck with SFI. Also changed wiring harness, with computer, fuse box, and a new fuel pump (60+psi).

The problem is that it will crank and fire and then stall. Upon further inspection, with a start button hooked up, hold the key in the crank position and it will start and run good. When the key is returned to the “run” position, it stalls, looses spark.

The ignition coil system is hot with the key on, but will not spark unless holding the crank position. Crank position sensor checks out as does the coil and coil controller. I would appreciate any thoughts! Thanks


#2

Since your are the band leader here what do you think? is the problem related to an installation error you have made? is the problem related to some error you have made installing the new harness? was SFI ever an option in 95? is this a security system influenced error? lets us know what you think is going on based on what you see.

Should you concentrate on why you lose +12v to the coils in the "run’ position? Is this a “passkey” or “passlock” 1,2, equipped vehicle?


#3

See what is getting power other than the starter solenoid when you have the switch in “crank”…The crank position (on your switch) is feeding something else besides the starter. You need to feed that circuit from the “on” position instead of the crank position. Sounds like it might be the fuel pump relay…


#4

Well, first of all, I’m not losing 12v at the coil, I’m just not getting a crank signal(pulse) during the run position, but the crank sensor has voltage. As far as the security issues, I don’t have a scan tool to see what else it might be. I dont see where any errors could have been made with the parts given to me. All of the connectors have a home except for one 2-pin connector near the throttle positioning and auto idle sensor. I also dont yet have the correct throttle linkage installed and this connector may have something to do with cruise.?. The O2 sensors are not hooked up as well.
I was under the impression that most security issues wouldn’t let it crank? The fact that it runs good in one position and not at all in the other leads me to believe that I have a PCM issue, possibly a wire in a different spot from the key switch to the firewall connector. Not sure on options, but my next step would just be to go with a different intake and a carburator.


#5

The problem might be with the ignition module.

Ignition modules function in two modes. These are the start and run modes. During starting of the engine the ignition module is in the start mode and allows full battery voltage to the ignition coils to ensure that a cold engine with a rich fuel mixture starts. Once the engine starts and the ignition switch goes into the run position, the ignition module switches to the run mode and steps the voltage down to the ignition coils. This is done because not as hot of a spark is required to keep the engine running, and also to prevent the ignition coils from overheating from the higher voltage.

Tester


#6

Crank, fire and run, then stall is a indication of an activated passlock system, the problem I have is 95 seems awful early for passlock.


#7

ok, I went right to the ignition switch, and the only thing that changes between run and crank, other than the yellow crank (solenoid wire) being energized, is a large (maybe 10gauge) orange wire drops from 12v to 2.37v during crank. tried to make some jump connections to the yellow crank wire, still wont stay running, unhooked the orange wire and tried to feed some resistance into the connection, but no luck there.
So, I don’t think it’s a power issue, I believe it is a PCM issue dealing with this change in resistence. Does this still sound like security issues?