Losing antifreeze, and boy can I smell it!

saab
9-5

#1

Only of warm days my car revs on it’s own while at a stop. After about 15 minutes of driving (and reving) while I’m at a light (almost always the same one) I will smell antifreeze and when I get home I’m down about a pint or two. Had the car checked, they said no leaks. I don’t know if this is one problem or two. Thanks for any direction, I already spent $600 on the reving (changed coils and sparks). BTW, I never find it under the car when it’s been sitting. It’s a 2002 Saab wagon with about 112,000.



Renee


#2

A competent mechanic should be able to diagnose your obvious leak causing coolant loss. The results could be expensive, any dampness on the passenger floor? That could indicate a heater core, otherwise it mayh be a loose hose clamp or pinhole leak. It is better that you can smell the antifreeze as that probably rules out head gaskets as a source of the problem.


#3

I think you might be confusing revving with the radiator fan coming on at this stop light. Do you have a tachometer, and is the car surging in neutral so that the tach gauge jumps up?
I think you are losing fluid while driving, but the car’s cooling system is holding it’s own so that the car is not overheating. Therefore when you shut the car off, the system is not boiling over and leaking coolant on your driveway.
It may have no leaks but your car’s cooling system at least is losing pressure, allowing the coolant to boil while driving and causing coolant loss. I’d replace the pressure cap first.


#4

It’s probably 1 problem. Oftentimes low coolant can make your engine rev because it confuses the ECU. At idle, the water pump can’t get enough coolant past the temperature sensor, which then registers a drop in temperature. Seeing this, the ECU assumes the engine is cold and goes into cold-loop mode, which dumps more fuel into the cylinders, which makes your engine rev. The faster engine speed allows the water pump to get coolant up to the sensor again, which then registers that the temp. has gone up. Seeing this, the ECU goes back to normal, stops putting extra fuel in the cylinder, the car goes back to idle and the cycle repeats.

So, you’ve got a small coolant leak that’s happening, and when enough leaks out it confuses your ECU and you get the second symptom. For such a small leak (even a pinhole leak can cause an overheat, so this one has to be REALLY small) I’d start with the radiator cap. If it’s no longer applying the pressure it should, it can cause coolant to steam out slowly enough that you won’t even notice it when you’re driving, but you’ll definitely smell it when you stop.


#5

Taking a WAG, but if you have a pressure cap on the plastic resivoir tank then maybe the plastic tank is cracked. if the pressure cap is on the radiator then this does not apply.


#6

Thanks for the feedback! I’ll try the caps first. Boy howdy waterboy, “competent” would be a good qualifier!

And yes kizwiki, I do have a tac and I can see it swing up and down when I’m sitting at a light.

Thanks everyone!