Intermitant reving


#1

I have an frequent intermitant problem. My engine will rev up on its own. When this happens, I can take my foot off of the gas and still get from 0 to 30+ mphfairly fast. While braking, it is still trying to go. In park, it will run 3000rpm. A very few times, the check engine light comes on and then will go off later, this is usually occurs when revving, but 2x’s it did not.



I have noticed that this “usually” happens when my vehicle is iced over (-5 to 40 degrees). It may run fine and then the reving happens. If I park the vehicle with the sun shining on the engine hood, it usually will not happen when I later restart.conjuction with the revving, but not always.



Any suggestions? My mechanic cleaned the throtle chamber, but it did not help. Now he says that the idle sensor in going out.



Olds Aurora 2001 3.5L 65000 miles


#2

what are the error codes? Your mechanic should have them.


#3

Perhaps this will help.

A broken or loose TPS (Throttle Position Sensor) can cause intermittent bursts of fuel from the injectors and an unstable idle because the PCM thinks the throttle is moving.


#4

The first time the engine light came on, and then off before they saw it, they found no codes. Hard to beleive, but the light only goes on when they are closed or I am at work. The last times, I was on lunch and drove straight to the shop. That is when they checked the codes and said “they think it is the sensor”
Thanks for your help


#5

Three things, in particular, need to looked at/checked/cleaned: the tps (throttle position sensor), iac valve (idle air control), and the throttle linkage/plate. Instructions are in the Haynes or Chilton’s repair manual. Liberal use of a spray cleaner in the intake tract could help.


#6

Thanks to all for your suggestions. Working a LOT better, but still some problems. It now only does it 2-3 times a week instaed of 4-5 times a day.

They replaced the sensor. They supposedly checked and cleaned the iac valve (idle air control), and the throttle linkage/plate as suggested. They aslo readjusted the computer.

I have to drive up a steep incline and back into my parking space. After I put it in reverse and start backing down the hill, the motor will start revving. It will still rev when I restart later. After I get on the street, and turn the motor off for 5 seconds and restart, the revving has stopped. This is the only time it happens now. Any suggestions

Again, Thanks