Help!

impala
ls

#1

I own a 2000 Impala LS V6 it has been giving me problems such as doing a lot of shaking and when in drive makes the sound of a noisy truck so I changed the pick-up in it and the noise stopped and the shaking but not it hesitates…Does anyone know this would be. Does the car need to reset? Also, not my check engine light is on and the service soon…Please help me with some feedback.


#2

Your first step is going to be scanning the car for codes rather than blindly throwing parts at it. AutoZone, Checkers, Advance, etc. will do this for you free. Post any results back here.

I don’t know what this “pick-up” you refer to is and I would advise not driving this car any more than absolutely necessary since it’s running so rough and the CEL is on. This may only make a minor problem a major one.
And don’t assume that if an auto parts house gives you a code POblah, blah, blah, whatever that the code means that a particular item needs to be replaced. There may be more to it than that.


#3

Thanks for the advice! I will do this in the morning. The pick-up connects to the coils. The coils is suppose to be like a big spark plug. I just would like you to know that you are talking to a female that knows very little about cars


#4

“when in drive makes the sound of a noisy truck so I changed the pick up in it” Ha ha ha

Just kidding!

BTW, FWIW msam0785, you have the #1 forum tech offering you help in the name of OK4450.


#5

Seriously? GM hasn’t made a reliable product since the early 70s. Do yourself a favor and trade that GM product in for something that is going to be more reliable - longer then four years. GMs problems have just begun to be made mention in the media.