Help my idiot light is on


#1

I have a 2003 Subaru Baja with 150,000 miles on it. For 9 months my engine light has been going on and off. I have done everything I can to no avail. When the light is on the car runs rough and chugs and occassionally stalls. This can happen at 50 miles an hour when I push in the clutch to slow down or stopped at a red light. I have been to my trusted mechanic and the Subaru dealer. It has been plugged in and they all say it has something to do with the ignition system, but no real clear problem. I just spent $400.00 to get the Air intake control replaced and that didn’t work. What is going on? Any help is very appreciated.


#2

When That Light Comes On, Your Baja Is Remembering Trouble Codes

Posting the specific code(s) here will give people a better chance to help you. If you don’t know what codes are currently being stored, go to a large Auto Parts, like Advance or Autozone and have the codes read. Most do this free of charge. Write down all codes exactly, such as PO2923 and post them here. Is there only one engine option for this vehicle? Which engine do you have? If you know, tell us that, too.


#3

If the problem is in the ignition system, why did they replace the air intake control? Why aren’t they fixing the ignition system? I don’t understand this at all.


#4

Hi Again,

Thank you for responding. I did get the code today for the problem with my car. It is P0519 - IAC System Performance. The repair they did yesterday was a valve assembly y-air (Idle air Control). At least that is what it says on my receipt. They put in a new IAC.

The first time this happened I brought it to a Subaru Dealership and they plugged it in. They said they cleaned out a little gunk, but that was all they could find. The second time I took it to the my mechanic they did the same thing and told me if the cleaning didn’t work then they would have to replace the IAC which is what they just did.

The car is definately running better (smoother), but the Check engine light has come back on and the code is the same as before.

I have the Subaru Sport version of the Baja and not the Turbo. It is a 4 cylinder engine, but I don’t know the specific size. Please let me know if there is more information you need.

Thank you
lrv1962


#5

Hi Again,

Thank you for responding. I did get the code today for the problem with my car. It is P0519 - IAC System Performance. The repair they did yesterday was a valve assembly y-air (Idle air Control). At least that is what it says on my receipt. They put in a new IAC.

The first time this happened I brought it to a Subaru Dealership and they plugged it in. They said they cleaned out a little gunk, but that was all they could find. The second time I took it to the my mechanic they did the same thing and told me if the cleaning didn’t work then they would have to replace the IAC which is what they just did.

The car is definately running better (smoother), but the Check engine light has come back on and the code is the same as before.

I have the Subaru Sport version of the Baja and not the Turbo. It is a 4 cylinder engine, but I don’t know the specific size. Please let me know if there is more information you need.

Thank you
lrv1962


#6

well, I guess there are no answers for my particular problem. At this point I guess the question is; should I be getting rid of this car.