CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

Heater Causing Overheat

I have a 2001 Grand Am GT with the 3400 V6 engine. It has 180K miles on it, but seems to be running great, until yesterday. I noticed that my Low Coolant light came on. My reservoir was full, so I just left it and went to work. After work, the light did not come back on, so I figured it was a fluke.

Today, when I turned the heater on to full heat, full blow, the engine spiked to 260 degrees and I pulled over. Driving without the heater on, the engine resumed its normal 200 degrees and everything seems fine, except the Low Coolant light is on again. Any suggestions?

First, check the coolant level in the radiator, not the overflow, cold. The fact that the coolant overflow is full does not necessarily translate to a full radiator of coolant.

Top off if needed with appropriate coolant/water mix. Then see if that changes the heater situation. The spike in the coolant temp may have only coincided with the full heat turn-on.

I agree. The heater is not causing the engine to overheat. Lack of coolant in the radiator is the likely problem. You must open the cap and check the level inside the radiator. It should be FULL, right up to the cap.

Do this when then engine is cold.

Thanks for the help. I will do this tonight after I get home and test it in the morning.

You’re going to find that your vehicle doesn’t have a radiator cap. So there’s no way to check the coolant level in the radiator. The pressure cap is located on the coolant reservior.

The problem might be caused from trapped air in the cooling system. To remove any trapped air, get the engine up to operating temperature. With the engine idling in park, slightly loosen the upper radiator hose clamp. Take a flat bladed screwdriver and slip it between the upper radiator hose and radiator hose neck to allow any air in the cooling system to purge out. Retighten the hose clamp.

Tester

When you say spiked you mean the needle went up in a few seconds or did it take a minute or two? When you pulled over how long did it take to cool. Was there any other evidence of overheating, like the reservoir near overflow?

I just wonder if it’s really overheating or some electrical gremlin. Try turning the blower up and down with the car standing still and idling.

Thank you guys for all the help. After investigating your suggestions, I decided to take the reservoir completely off and check the hoses. My reservoir was empty.
I pulled the reservoir off, cleaned it, and checked the hoses. Everything was fine.

I put everything back on and was going to fill it up. I went to twist the relief valve. The last one to fill it (not me! the dealership.) did not tighten the valve. Therefore, all of my coolant had been spewing up and out of the relief valve.

Thanks for the quick responses.