Flashing Check Engine Light after Repairs

#1

My car is a 1999 Honda Civic LX. About 3 weeks ago, the Check Engine light went on, steady, no flashing. On the Honda place’s advice, I drove it around for over a week to see if it would go off. It didn’t, so I took it in for diagnostics. They replaced a primary oxygen sensor and some piece that connects the exhaust system to the engine.



This was in Wisconsin. I was/am traveling and left Wisconsin a couple days later. Since then, I’ve driven it around a good deal - first south, then to upstate NY.



Tonight, just as I was pulling into a parking space, the Check Engine light went on, flashing this time. At the same time, it sounded and felt like something disconnected. The engine made a panting noise (or maybe like a paper tapping against a fan).



I’ve arranged for AAA to have it towed in the morning, but meanwhile I’m terrified wondering how much more this is going to cost me. (The first set of repairs cost $1,100, and they said nothing else looked like it would need work.)



Is it possible that something they did just came loose and can easily be reattached? I can’t exactly have it towed back to Wisconsin for them to fix.



Any thoughts? Any advice? I’m feeling really bleak right now.

#2

I can’t figure out how to edit my post, so I’ll add this one. I just wanted to say that the exhaust system had been replaced a few years ago, as was a secondary oxygen sensor.

Also, what I meant to ask is whether anyone has any ideas as to what is wrong with it now?

#3

That CEL (check engine light) is just a kid in class waving her hand trying to get you attention because she has the answer. You need to have the codes read. Some places will read them for FREE. Try Autozone or Advanced Auto Parts. Get the exact code (like P0123) not just their translation into English and post it back here.

Regarding warning lights:

  1. if the coolant temp light comes on, shut off the engine ASAP

  2. if the oil warning light comes on, shut off the engine ASAP

  3. if a FLASHING MIL/CEL comes on, shut off the engine ASAP

    ASAP means driving to the berm of the highway right now and not waiting for the next exit.

But if the MIL/CEL is not flashing, then it’s not an urgent indicator.

#4

Wow, Joseph, you must have that post rigged with a hot key to insert that same post. I believe the OP is doing just that, just nervous about the outcome.

Something has gone terribly bad, tho. A bad sound from the engine coupled with a flashing CEL is not good. Your lucky it happened just as you were parking. This certainly minimizes any damage. I don’t think this has anything to do with the repair 3 weeks ago. That work was simply exhaust work downstream from the engine components. Even if the exhaust were to completely fall off, I don’t think this would trigger a flashing CEL.

Something on the engine broke loose. This car being 10 years old, unknown miles, but I’m guessing well over 150,000, anything can break at any time. I’m sure it won’t take a mechanic long to find it. BTW, just a WAG, but when was the last time you changed the timing belt?

#5

Yeah, something definitely felt like it disconnected, but I hoped it was the work that was just done. Replaced the timing belt at 105,000 miles and now have 153,000 miles, so it shouldn’t be that - but it could be. It was making noise like a loose belt for over a year now. Mechanics replaces all other belts and the noise never went away - well, it’ll be towed this morning and I guess I’ll find out soon enough.

#6

Well, for anyone who wondered, it turned out that something was misfiring and burned into one of the wires. Wire got replaced, and now it feels better than it has in ages, which makes me wonder if it wasn’t misfiring all along and why the diagnostics 3 weeks ago didn’t catch it.

Down another $187, though.

#7

$187, and you didn’t get your hands oily? Whatta Bargain!