CarTalk.com Best of Deals Car Reviews Repair Shops Cars A-Z Radio Show

Engine coolent smell

I have a 2015 Cadillac CTS 4 Turbo bought new with 22K miles. Always smell coolant after pulling into garage and in the vent system in the cabin when first starting up after vehicle sits all night.
Dealership cannot find any leaks or reason for the smell.
Any suggestions as to the cause?

Have you immediately opened the hood and sniffed around?

You may have a leaking heater core. Perhaps a radiator shop could better diagnose it.

Sounds like the dealer isn’t interested. Perhaps he hopes that if it never gets fixed you’ll trade it for a new one… and THEN he’ll fix it!

1 Like

Simply having a somewhat loose hose clamp on one of your radiator hoses could be the source of the problem. Quite a few years ago, I had similar symptoms, and despite not having any measurable loss of coolant, I finally traced the problem to a radiator hose clamp that just needed to be snugged-up by a tiny amount.

1 Like

I would look at the heater core too. Might be small leak that’s evaporating before it drips on the floor. Could be leaking in the engine bay though. You need to look at it when the engine’s fully warmed up.

Bring the vehicle back to the dealer and ask that they add a couple of these tabs to the cooling system.

They may not have added enough of these at the factory.

Tester

1 Like

Sorry, but I’d recommend a diagnosis and repair instead.
And I wouldn’t take the car back to a dealer that did nothing useful the first time.

The car’s fairly new, so it’s not likely to be anything critical. VDC made a good comment about a simple loose clamp possibility. The cooling system is pressurized, typically about 15-16 psi, and a loose clamp is all it would take to allow seepage.

NOTE: normally I would not suggest taking a car under warranty anywhere other than the dealer, but in this case it appears that the dealer is uninterested.

It’s NOP to add these tabs if a leak can’t be found.

http://www.acdelco.com/auto-parts/vehicle-maintenance/mechanical-repair/cooling-system-seal-tabs.html

Tester

How do spring clamps become loose after three years? Rust?

Are you having to add coolant once in a while to keep it topped up? If so, how much & how often? If you don’t ever have to add coolant, then the odor isn’t coolant. If you do have to add a little coolant from time to time, then you probably have a small coolant leak, probably more like a weep that’s evaporating rather than dripping to the ground. If you can find the water pump, look for signs of coolant stains in that area. Also see if you can find a small hole either on the top or the bottom of the pump, near the shaft. That hole is supposed to be there. If the shaft seal is leaking, coolant will seep out of that hole. If you look into that hole and see a bit of a damp surface in there, don’t worry about that, normal. Only if coolant is seeping through that hole, then you might need a new water pump eventually.

I had a similar symptom on my Corolla, noticed a little coolant odor pulling into the driveway after a long drive. Also I was having to add about 1/2 cup of coolant every 6 months to keep it topped off. In my case I finally traced the leak to a faulty o-ring seal where the metal return pipe attaches to the water pump.

My advice: As long as you don’t need to add more than a cup of coolant every 3 months to keep it topped off, and the engine never overheats, just keep an eye on the coolant level. Otherwise don’t worry about it.

1 Like

Manufacturing error.
Perhaps they were installed on the Friday before a holiday weekend.

The clamp’s springy-ness is due to the metal alloy used, and the heat treatment they receive. An error in either of those, or a problem with the part’s dimensions could cause spring clamps to loose their grip with time and engine compartment heat. Seems unlikely, but such a thing could happen I presume.