CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

Alternator problem?

So earlier today when I tried to start my car it wouldn’t start! I tried cranking her over twice and I got nothing. The battery gage needle didn’t move when I tried starting her up the few times. What’s weird is that I took my other car (parents) out to run the errands I needed to run and when I got back I thought to myself “well maybe the battery is dead and needs to be jumped” that makes sense right? So as I pull up next to my car I decided to try starting her one last time and when I put the key in and cranked her over she started right up! Not a stutter or anything! So I’m left with the feeling that maybe it could be a failing alternator ? Or possibly a loose cable or something ?

Btw the car is a '98 Mercury Grand Marquis.

I’m gonna guess a corroded battery cable connection or loose battery post (internally) or something of the sort, but it’ll need to be looked at to truly diagnose it. Other possibilities include a worn out key cylinder.

@“the same mountainbike” hmm do you think that’s something I could have my local Autozone look at? Or is it better to just take it to a trusted mechanic ?

To get a diagnosis *

Take it to a trusted mechanic. AZ guys can mount a tire or change a battery, but you’re better off with someone with true diagnostic skills.

Use the web to find a video on cleaning battery connections. It is not difficult at all. Cheaper than a $100.00 diagnostic fee you might not need.

Alright will do… Would something like a corroded battery cable or loose post make it not work in colder weather? It was around 55 degrees this morning when I tried starting her., Just wondering because it was warmer around 1 today when she fired right up

@“VOLVO V70” will definitely try that first!

Idk if the posts look dirty or what not… But this is what they look like. Will try cleaning them tomorrow and post back results.

Here we go.

Those don’t look particularly corroded, but it is the part not visible – the surfaces between the connector and the post – you need to clean. You’ll need a special and inexpensive battery post tool gadget to do that.

A couple of other common reasons for this symptom are a faulty neutral safety switch (for an automatic), or faulty clutch safety switch (for a manual transmission). But before going down that path, make sure the battery connections are tight and clean. If the battery is over 4 years old, 3 if you live in a hot climate, that should be high on the list of suspicions too.

@GeorgeSanJose that’s what I thought but I’ll clean 'em anyways and see what happens… Any idea what an estimate would be on what you mentioned in your comment above ? Cars an automatic btw.

Replacing a neutral safety switch isn’t usually very expensive. But a good mechanic wouldn’t replace one just b/c this symptom is occurring. They’d find out why the symptom is occurring first, the replace or adjust the part that is not working. There’s a least a half dozen common reasons for the “fails to crank” symptom.

Hmm alrighty then :slight_smile: I’ll try and start her tomorrow morning and see what happens. And also give it a clean down.

Given the age I might suspect the neutral safety switch (allows it to start only in park and neutral) may be failing. This is referred to in more technical terms as a range selector switch.

If it acts up again try shifting into neutral to see if it starts. If so, it’s likely the switch is bad. The switch is not a major repair at all; if needed.

You could search this forum for “cranking” problems and see what kinds of solutions others have found for this symptom.

Saw a couple of different posts on cranking problems… I guess it could be possible a fuel pump relay is shorting and could need replacing ?

Oh also the fuel pump itself was replaced just two years ago so I don’t think it would be that

A fuel pump relay wouldn’t be the usual explanation for a fails to crank. That would likely be in the cranking system, so a battery, safety switch, ignition switch, starter motor, etc.

Gotcha :slight_smile: just wasn’t sure.