Alfa 75 3.0 V6 Bogging on Acceleration & Slow to Start



True, but my Corolla is of similar vintage. It’s true newer cars tend to use higher fuel pressures.


Sure doesn’t sound right. Try testing with the cap off.


I don’t think it’s wise to be making these assumptions, that only very old systems have high pressure

Bosch CIS is even older than your Corolla, and it has significantly higher pressures

I feel the best approach is to not assume that OP’s fuel pressure system is within spec. In my opinion, this is where a decent service manual . . . or at the very least, that Bosch book I mentioned . . . comes into the picture

My memory’s hazy on that book, but I believe it had function descriptions, specs, and troubleshooting.


Definitely, if OP has access to one, that’s where to look for the specs. You are right, no need to guess.


Please forgive me for saying this, but you’re contradicting yourself, in my opinion

You have no idea what OP’s fuel pressures are supposed to be, unless you’re somehow holding out on us?

And you said the numbers he provided sounded okay, because your car is of similar vintage

If that’s not guessing, what is?

In the shop, I’ve gotten myself into some bad situations, when I assumed something was okay, instead of looking up the specs, proper procedure, etc.


Simply a learning project. No rush to get it on the road


As said earlier, I am also posting on the alfa forum and receiving some more specific responses. However I am receiving a lot of general knowledge on this forum and since I have very little experience I’m finding this very useful.
Fuel delivery pressure specs are 32.71 - 38.40 psi with the pressure regulator vacuum hose disconnected.
The L-Jetronic Bosch book you liked me has been extremely useful, although mentions no issue similar to what I am experiencing


The gauge does rise quickly when bumping the accelerator, and falls again with releasing accelerator. The pressure also holds at a steady 25psi at any held RPM.

The MAF has a microswitch. When the MAF is opened (when the engine turns when the starter has been engaged), it activates the fuel pump for starting. Opening the MAF manually with the ignition on allows the fuel pressure to be measured.

35PSI is within specs.
The issue that I’m having doesn’t seem to be as a result of the engine warming up, as I was driving the car fine for about 10/ 15 minutes at full operating temperature. About 30 seconds after the pressure did drop and started to run rough and stalled out, I opened the MAF manually (with engine off), the pressure jumped back to the full 35 PSI, started fine and ran for another 15/20 minutes. It continued to run fine so I turned it off and called it a day.

So the issue doesn’t seem to be as a result of heat, but simply after running for a while. I’ll carry out a voltage check on the fuel pump, but I would say its fine. As I said, after the car has been running for a while, the fuel pump gets louder and louder as if it’s working harder.


As another guessed, my guess is a weak fuel pump.


Sorry to hear the book didn’t entirely solve your problem

Glad to hear the fuel pressure is indeed within specs

This MAF sensor you keep mentioning

MAF stands for mass air flow, a MAF sensor has no moving parts

Yet the way you talk, it sounds more like a vane air flow meter, an older technology with a movable vane

This is a typical MAF sensor

And this is a typical vane air flow meter


Which do you have?

They don’t work identically, and their functions are simliar, but not identical. Anyways, If you have the vane airflow meter, I’m wondering if the vane or the spring are damaged, or maybe the device is defective in some other way. It can definitely affect proper fuel pump operation, if my memory serves me correctly. It’s been awhile since I encountered one of these

Since you didn’t actually remove and drain the tank, I’m wondering if there’s still crud in there. Could be the sock filter is in dire need of cleaning/replacement. Or perhaps the filter’s picking up the crud, which is making the pump strain


@db4690 - did you see this comment from the OP?


Yeah so it’s more like the vane meter. When I say I open the MAF to activate the fuel pump, I’m fully opening that vane by hand. Apologies for the confusion. I seems to be working ok, although it could be temperamental, and I could do with properly testing this to be honest.

As texases quoted me, the drop is pressure is only after 10/15 minutes of running at operating temp. Although I do agree that there may crud blocking something. I think I’ll take out the fuel tank as my next job. Just a bit strange that after turning off the engine for a few seconds, the pressure is able to rise to normal again (by opening MAF) and then run fine. The idle is a little unsteady.

As a side note, the cold starting issue has been resolved - it was a faulty cold start injector.


Yeah, I saw it

But I’m not yet 100% convinced the fuel pump . . . which OP replaced with a new Bosch unit, apparently . . . is the cause and not the symptom


Ok. I missed the ‘replaced the fuel pump’ step…still reading that other thread :grin:


There might be a slurry of rust particles in the bottom of the tank plugging the inlet screen. If the inlet screen has fallen apart the contaminants will enter the fuel pump. Remove the inlet line from the fuel pump, capture the fuel from the line and inspect for rust.


On my Rabbit’s K-Jetronic CIS system I’d have to manually pull that vane upwards to get the fuel to flow to the injectors for testing purposes. I’m surprised a 1988 vehicle would still use that vane technique. The way the K version meters out the fuel in correct proportion to the airflow is that a piston-like device is attached to the air flow vane, so when the vane moves up so does the piston, and that piston’s upward movement opens a channel for more fuel to flow to the injector. The problem I tended to have was that piston’s movement would get gunked up by grit and it wouldn’t move smoothly. If you have that piston arrangement in your L version, remove the piston from its bore and make sure it and the bore is 100% clean and the piston moves in its bore smoothly. I don’t know how the L version is configured, you may not have that piston/bore arrangement in the L. But make sure that vane moves smoothly over its full range in any event.

If that’s not the problem then

  • something is partially blocking the flow of fuel, perhaps remaining debris in the tank
  • or the pump is faulty,
  • or the power supply to the pump is faulty
  • or there’s some interaction between the L’s electronics and the vane that’s not working properly


No disagreement, I have no experience with the Bosch L version, and don’t have access to the repair and diagnostic procedures for that version either. But I do have experience with the K version, so I wouldn’t agree that my ideas for the OP are entirely a guess. Hopefully they are somewhat worthwhile.

While I don’t know the exact fuel pressure spec for an 88 Alfa, no doubt about that point, I’m still pretty sure the pressure is not supposed to be falling like the OP describes. I’m guessing figuring out what’s causing that is the key.


The MAF is still electronic; as air passes through the sort of butterfly valve, the valve opens (more with more airflow) which in turn rotates an electronic switch.

Thanks for your replies. I’ll run some tests and check for blockages some time next week.


I had some really difficult to diagnose problems on my K-Jetronic with the fuel pump relay. If I had those symptoms you have on an L-Jetronic, without any other ideas, that’d be my first suspect. Replacing the fuel pump relay btw didn’t fix the problem, b/c the problem wasn’t the relay itself, it was inside the relay plate that the relay plugged into. Measuring the voltage at the fuel pump connector is one way to do the test. If your system has a return hose at the pressure regulator, the voltage at the pump should probably be constant if things are working correctly.


Back again. Issue still not solved. Any ideas would be appreciated

Current Issue: Loud whining fuel pump (brand new), and engine bogging on acceleration after about 10 minutes of light driving.

Recent Work Done:
Suspected a blockage in the fuel tank, so we began to drain it from the main outlet (gravity fed at the bottom of the tank), and noticed that after a few seconds of draining, it went from full flow to a slow trickle, almost stopping. The tank had at least 10ltrs in. We decided that the intank mesh filter must be blocked so we gave it a knock and the fuel started flowing again. We decided that this must be the cause of our poor running, and the cause of the whining fuel pump.
We removed this filter and instead installed a small inline filter. Fuel now flowing freely out the tank by gravity - no blockages before the fuel pump. Just been for a test drive, and the fuel pump is still whining (???) and engine bogging after about 10 minutes.

What could be going wrong, and most importantly, why is our brand new fuel pump still whining?! This has to be a clue to our running issue

We have also checked the fuel pump supply voltage - all good