CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

AC Compressor-Hard to locate noise

Had ac compressor replaced on 2002 Toyota Camry V6 at a shop that works only on imports and has been in business 30 yrs. New compressor ran and cooled well. When inside car and compressor engaged, there is a humming/whinning/cooing noise that speeds up/down when accelerator is pressed/released. If I click compressor off or it disengages, you cannot hear noise. The noise can be heard from outside when compressor is engaged with hood up but it’s not as loud (I think running engine is muffling some of noise)and can’t tell where it’s coming from. I took it back to shop. He could not locate exactly where it was coming from. Said he took serpentine belt loose and checked pulleys. He did not think it was the new compressor but did decide to get another compressor. Second one runs and cools good but there is still the same noise. He let me listen to the new compressor and existing alternator with a mechanic’s stethoscope. Compressor sounded smooth when engaged but the alternator was much louder through the stethoscope when compressor engaged. He now thinks the noise is coming from the alternator. Again, with hood up and compressor engaged, you can’t zero in on where it’s coming from. He thinks the new compressor when engaged is putting more of a draw on the alternator which has a 170,000 miles on it. I asked if he was telling me that I needed a new alternator. He said no as far as functioning of it. But if the noise is coming from it, that’s the way to get rid of noise. I was referred to this shop by three different people I work with. Has anyone ever ran into such situation and what is opinion.



So I guess you don’t want to change the alternator?

I just to make sure it’s the right diagnosis. The noise was not there before the ac compressor was replaced and now it is. If it is fact the alternator, I will replace it.

I don’t think he means electrical load on the alternator. Your alternator and AC compressor are both run by the same serpentine belt. Because of the way the belt is routed, I suspect that the added mechanical load on the belt is causing added lateral loading on the alternator pulley, causing the worn front bearing to become nosy.

Try removing the serpentine belt and spinning the alternator pulley by hand. Try also wobbling the pulley both laterally (sideways) and axially (in & out). You may discover a bad bearing. The fix is a new alternator.

By the way, is this a repost?

Have you checked for Tecniacal Service Bulletins? Perhaps the “discovery” part of fixing this mysery noise has already been done

It’s a repost of a repost.

A length of garden hose makes a good stethoscope to find these kinds of noises.

BTW, please keep all comments in the same thread.