98 Jeep Cherokee Laredo not starting

jeep
cherokee

#1

I was hoping someone could help identify an issue for me. My Jeep will not start. I can put the keys in the ignition and try to start it and nothing will happen. No sounds, clicking, nothing. The battery is fine, I replaced it with a new one, made sure it was charged and nothing happens when I try to crank it. The interior lights dont come on when I open the door but if i turn them on, they come on but they are very dim. Automatics locks dont work, horn doesnt work. I tried to jump start it with the new battery in with my other car. It tried to turn over but wont come on. It just sounds like the battery is dead when I try to turn it over. The vehicle in question is a 98 Jeep Grand Cherokee Laredo.


#2

I’m fairly certain it’s an electrical problem but I have minimal knowledge on identifying the problems in vehicles.


#3

You’re going to have to identify why the various electrical gadgets aren’t getting powered up first before focusing on why the car doesn’t start I think. Since you have a known good battery and it is fully charged, that shouldn’t prove too difficult for an auto-tech with some training in auto-electric diagnosis. Could be the battery connectors are corroded. One time I had a problem similar to this on my Corolla, the battery was leaking and the acid decanted down a main harness, and ate away a splice midway down the encased harness. It takes a little electro-sleuthing, but whatever bad connection exists can be found using a systematic search and the car’s wiring schematics.


#4

I’ve been pulling fuses to figure out the issue but still cant identify it. About to inspect the wires and connections. I cleaned the battery terminals and connections. My previouse battery was sputtering acid between the terminal and connectors.


#5

This is sort of like if you have a pipe and you know water is going into it, but no water is coming out. The pipe is broken, you know that for sure, the only question is where. So with a pipe, you might pick a point halfway between where you know it has water and it doesn’t, see if the water is still in the pipe there. Same technique works with wiring problems.


#6

Should point out this could be a ground side problem too. Have you compared the battery voltage by measuring between the posts, then measure between the battery positive and the chassis? If they are different when this problem occurs (where the electrical gadgets aren’t working), that’s a clue you have a ground problem.