CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

2010 G37x haunted?(electrical issues)

Hi everyone I am having some electrical issues with my vehicle. I looked all over the internet and didn’t find anyone with similar issues to mine (or maybe I’m bad at looking). I am hoping one of you will be able to guide me in the right direction.

What happened:
Before I start I think it’s connected to humidity/moisture in the air because the only times I’ve had these issues were when it rained heavily.

One rainy day while driving, my trunk latch automatically released and the trunk opened up. I got out and tried to close it and it wouldn’t latch. Somehow I got it to close and stay closed. Then when I tried to open it it didn’t open. The local button, the keyfob button nor the button in the car worked. So i just left it at that.

After I got back in the car tried to open my power windows and they did not work.
Lights inside the car started to flicker (door lights, button lights, dashboard), not while hitting the button or anything just randomly after I tried to open the windows.

Turned the car off, got out and tried locking the car with key fob. Lock button didn’t do anything.
Tried to lock it using the mechanical key from the key fob in the keyhole, didn’t do anything.

Tried hitting the unlock button and now that made the headlights flash and tail lights. But just the drivers side lights (front and back)

Tried it again this time all 4 sides flashed.

Tried it again this time just the passenger side. (repeated this multiple times with various results)

Turned the car on and turned all the headlights/tail lights on and they seemed to work just fine (all 4 were lit)

Tried the windows again, nothing.

Tried to turn off the car(push to start/stop) and that didn’t turn the engine off, it didn’t do anything. After a few times lights all started flickering (inside and out).

Turned off the car somehow by repeated tries after locking/unlocking the car multiple times.

Tried lock button seemed to work this time (but only 2 of the 4 lights worked)

Tried again to unlock and start the car and this time it didn’t start, all the lights (in the car) flickered a lot and made clicking noise). Checked the battery and it was at 12.6 Volts.

Left the car overnight.

In the morning everything worked fine, no issues, no check engine lights, no codes, nothing. One thing to note though when I started the car up and checked the battery voltage it read 13.3 ( seems low… maybe alternator issues?) This has happened twice now. The other time was similar but I didn’t try all the stuff. The trunk popped open so I knew something was wrong. Tried closing but it didn’t close, lights flickered, just turned the car off, locked it (worked that time) and left it overnight and everything was fine the next day.

What do you guys make of that. Any guesses? Alternator? Water getting somewhere its not supposed to? Fuse? Short? How would I go about diagnosing it? Let me know please, thank you for your time and input.

Suggest you start off w/ the standard diy’er battery/alternator test. The battery should measure about 12.6 volts before the first start of the day. Then immediately after starting the engine, 13.5-15.5 volts. If the voltages are ok, the next step is to ask your shop to clean the battery posts and terminals. If that doesn’t do the trick I’m afraid you’ll gonna need to find a shop with experiencing fixing in-car electrics. Of which this model has a lot.

I did perform the test when the issue occurred, but you’re absolutely right, I didn’t think of checking the voltages after letting it sit for a while, thank you. I hope it’s as simple as cleaning the posts and terminals that would be a blessing, even an alternator I can deal with, but if it’s a deep rooted electrical issue, I may as well invest in a new vehicle.

9 years old … difficult to diagnose electrical problems … hmmm … yeah, if the easy stuff doesn’t work, might be time to start looking for another vehicle. give this problem to some diy’er who needs a car and has enough experience & time to figure it out.

Just for stabbing in the dark, you might want to locate the body control module and look if it may have gotten wet. Unplug it and clean terminals. Might be worth a try. Disconnect battery before unplugging.