1999 suburu outback sport problem


#1

I’ve been having some car trouble for the past few weeks with my 99 outback sport. The check engine light started coming on for a few days then it would go off. This went on for a bit without any change in the car itself. All the fluid levels are good. This morning the check engine light blinked for about a minute while the car seemed to lug… It felt like I was driving in fourth while I should have been in first. Sort

of chugging. Any thought on what this could be? I’m not sure if this is related but every now and then I’ll hear a sharp squeak and the car will chug quickly. This seems to happen fairly regularly. Any help would be great.


#2

Have the trouble codes read by a mechanic or parts store. The codes will direct you to the source of the problem. If the check engine light came on, a code or codes has been stored in the computer.


#3

That CEL (check engine light) is just a kid in class waving her hand trying to get you attention because she has the answer. You need to have the codes read. Some places will read them for FREE. Try Autozone or Advanced Auto Parts. Get the exact code not just their translation into English and post it back here. It likely will have a format like P1234.


#4

As was already stated, you first need to have the codes read in order to know what is wrong.

That being said, I hope that you realize that continuing to drive a car when the CEL keeps lighting up is not a good thing. Service and repair that are delayed inevitably lead to more expense than if those tasks are taken care of in a timely fashion.