1991 Buick Century won't start

I bought a well-used 1991 Buick Century for my son in December '12. At that point I put in a battery that was bought brand new just the month before. The car ran fine until a couple weeks ago. He tried to start it but only got a slow crank, like a low battery. I tried to jump start it, with no difference. Since the car was at his school, I asked his auto shop teacher to take a look at it. The teacher tested the battery on two different machines and determined the battery was bad. I returned it to the store I bought it at, where it was tested as working fine. I then swapped the battery from my car for his, and his battery (the one that was tested bad) started my car with no problems while my battery would not start his car. It produced the same slow crank. I talked to the shop teacher again, who pulled the starter and took both the starter and the battery to various auto parts stores. The starter tested good, but the battery was tested bad at 3 shops, and weak at a fourth. So the car is still sitting at the school, and we’re at a loss. What might be causing this problem and how can we get his car running again, short of just buying another car?

@CMDecker can you easily turn the engine over by hand?

Try to turn it over manually with a socket and large breaker bar.

Does the engine have sufficient oil?

You might ask the auto shop teacher to check the battery ground cable and the positive cable going from the battery to the starter.

Are the battery cable ends clean and tight?

@CMDecker if the car uses these, replace them.

Many GM starting complaints have been because of these.


I haven’t yet tried to turn it by hand, but am planning to try it tomorrow. It does have oil, but hadn’t gotten around to changing it. I talked to a guy at an auto parts store, and he suggested the battery cables, ground cable, etc. I did make sure the terminal posts were cleaned, but could replace them. I will let you know how it goes tomorrow.


Yeah, I used to replace those screw in posts every couple of years just to keep them fresh. There are two sizes though. The short ones that go with the one cable connected to the battery, and a longer one for the post with two cables.

Did I read it wrong though that the battery tested BAD at the shops when it was out of the car? That wouldn’t mean cables.

Well, went to work on the car and the battery was dead. I took it to a shop and had them test it. The test came back low, but good. The guy did suggest I get rid of the steel posts and get lead ones instead because they conduct electricity better. At any rate, the batter is on a slow charge until tomorrow, and then I’ll see what I can do.

Okay, sorry for the long wait. I got a suggestion from another person to remove the serpentine belt and see if the car would start. Did that, and it fired right up. Turns out the a/c compressor is locked up and was bogging down the belt, preventing the engine from turning over properly.

Now my problem is, I need to get the a/c compressor out and replace it. I’ve bought a replacement pulley, since a/c isn’t necessary for this car. Unfortunately, I have one bolt that refuses to budge. I have stripped the head off trying to loosen it. I’ve soaked it in lubricant, used vice grips, and nothing. There is a water hose in the way that I can’t remove without cutting, and don’t want to replace that too. It’s not really in a position to get heat to it without risking burning anything else. Any advice on getting that bolt loose?