Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Squeaking noise in when AC or heat or defrost is run

I drive a 2006 Mistu Endeavor. When I turn on the AC/heat/defrost on any setting the car makes a squeaking/hissing noise like something being sucked up by the vaccum cleaner but it cant go thru the tube.... its loud on the middle fan speeds and doesnt go away when the car warms up... need help

Comments

  • edited December 2010
    I Can't Hear Anything From Here, But There's A Chance That A leaf Or Other Debris Has Literally Hit The Fan And Stayed There.

    Stuff sometimes gets through the air intake in the cowl ahead of the windshield.

    Have you tried differnt fan speeds while selecting different places for the air to exit (defrost, floor, dashboard vents) ? Sometimes this will dislodge it.

    A mechanic / technician should be able to give a listen and verify this. Some cars give easy access to the blower assembly and others do not.

    Without hearing it in the vehicle this is only one guess at a possible source of the noise.
    I suppose it could be a vacuum line that is leaking, instead.

    CSA
  • edited December 2010
    Does It Possibly Sound Like Water Being Vacuumed Up ?

    Lift up floor mats in the front and make sure the floor's not wet. I see several (many) bulletins pertaining to HVAC system drain tubes becoming clogged on these vehicles. When this happens plain old water accumulates in the Heating, Ventilation, and Air Conditioning housing and can't drain to the ouside of the vehicle as it's supposed to do. It can and does spill over.

    Check it out and back to us.

    Thanks,
    CSA
This discussion has been closed.