Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

93 Blazer fuel pump

I have a '93 Chevy S10 Blazer with 4.3L V6 engine.

Fuel pump not working when the ignition is turned on, no fuel pressure, no start!

I have changed the fuel pump relay. No success.

I am unable to find any fuse in the fuse block which affects this pump.

Is there a fuse or fusible link somewhere in the engine compartment?

If so, where? Helllpp!

Comments

  • edited February 2010
    HELLO out there!
    Not a sexy subject, I know, but I'd love some help if anyone knows ...
    Thanks so much
  • edited February 2010
    Do you not hear the fuel pump run for two seconds each time the ignition switch is turned to ON (or, RUN)? You know that there is no fuel pressure because..........? Have you changed the fuel filter? You should.

    The problem may be electrical. To find out if the fuel pump CAN run, there is a "prime connector" that you can run a +12 volt hot-wire to and power the fuel pump. The one-wire connector may be near the fuel pump relay, in the engine compartment. It's just a single wire that looks like it didn't get connected.

    The oil pressure switch supplies power (12 volt) to the fuel pump when oil pressure closes the switch. The fuel pump relay also supplies 12 volt power to the fuel pump when the engine computer energises the fuel pump relay.

    If hot-wiring the fuel pump, does make it run, there is a wiring circuit problem. You need a wiring diagram to know which wires to check, and a multimeter (or, test light) to check for power for the fuel pump. You don't want to change a good fuel pump because you didn't assure it has electrical power (Well, OK, I don't want you to.).
    Here is some information about checking the fuel pump: http://www.autozone.com/autozone/repairinfo/repairguide/repairGuideContent.jsp?chapterTitle=Central+Multi-port+Fuel+Injection+System&partName=Fuel+Pump+Relay&pageId=0900c1528003d99a&subChapterTitle=Electric+Fuel+Pump&partId=0900c1528003d99f You'll need to register at the autozone Web site to see the information.
    Here are the wiring diagrams to do the troubleshooting with: http://www.autozone.com/autozone/repairinfo/repairguide/repairGuideContent.jsp?chapterTitle=Wiring+Diagrams&partName=Chassis+Electrical&pageId=0900c1528003db5f&partId=0900c1528003da59 You need to allow about five minuets for the diagrams to load. Scroll down to Fig 47 and Fig 48. Print out, and trace the circuits.
  • edited February 2010
    Do not know about fuse but take a rubber hammer and hit gas tank 2 times with a good wack.
    Turn on key and see if you can hear pump while standing by rear bumper.
    If you hear it, pump is going out soon.
  • edited February 2010
    Thanks so much for your contribution!!
    Yes, I do NOT hear the pump running when I turn the key. I know there is no fuel pressure because no gas comes out of the pressure relief valve behind the plenum.
    It is a almost new filter.
    I live in Alaska and think some water ice from the tank might have got sucked into the pump. In fact, the car started up normally (pump ran) that morning then died after about 30 secs. The pump hasnt worked since.
    That is why I was hoping for a fuse or similar. I will try jumping the pump through the prime connection as you suggest but I might have to wait until things thaw out.
    I will also check the circuit diagrams you recommend since mine are pathetic.
    Thanks so much!
  • edited February 2010
    it maybe a starter relay or shifter kill switch?
  • edited February 2010
    The inlet to the fuel pump, in the gas tank, won't pick up a piece of ice because there is a filter over the fuel pump intake.
    If the oil pressure switch opens, it cuts power to the fuel pump. Loss of oil pressure would cause the oil pressure switch to open, AND CAUSE THE OIL PRESSURE WARNING LIGHT TO LIGHT ON THE DASH.
    The engine starts, and runs, for 30 seconds, and then dies? If it still does that, it could indicate that the oil pressure switch isn't powering the fuel pump. If the low oil pressure light doesn't come ON before the engine dies, the oil pressure switch could be faulty.
  • edited February 2010
    Thanks for your insights and helpful suggestions.
    Ever since it quit running the first time it hasnt fired up since.
    Oil pressure light does not come on when it cranks.
    I will look into the issue of the oil pressure switch. I now have wiring diagrams.
    Thanks!
This discussion has been closed.