Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

oxygen sensor for subaru legacy

edited November -1 in Repair and Maintenance
I have a 1995 subaru legacy with the standard 2.2L 4cyl. The check engine light came on, which turns out to be for code P0141, O2 heater loop fail, Bank 1 Sensor 2.



The first issue is whether this is a problem with the sensor itself or whether there is a problem with, for example, the wiring harness.



The second issue is that this code usually refers to a downflow sensor (i.e. beyond the catalytic converter), but I can't find anyone that sells anything specifically downflow for this model year. Does this mean that both sensors are the same part? Or do I need to get a "universal" sensor and crimp some wires together?
Tagged:

Comments

  • edited April 2008
    The DTC (Diagnostic Trouble Code) of P0141 is "O2 heater circuit". The word "circuit" means the wiring, engine computer, and oxygen sensor. These have to be checked to determine what part of the circuit is faulty. The fault could be in the wiring, or in the 12 volts power to it, or the engine computer, or the oxygen sensor.
    Here is a link to the instructions for testing, and inspecting an oxygen sensor and its circuit: http://www.autozone.com/az/cds/en_us/0900823d/80/1c/61/83/0900823d801c6183/repairInfoPages.htm

    Use a high impedance, digital multimeter to do the checks with. Use of a regular, old style voltmeter, can fry the engine computer. This is bad.

    The front and rear (downstream) oxygen sensors are probably the same. If the new oxygen sensor comes with a wiring connector, DON'T cut and crimp the wires, as they are probably shielded with metal braid or foil. Damaging the shield can mess up the signal from the oxygen sensor.

    Click on this to see the wiring diagram: http://www.autozone.com/az/cds/en_us/0900823d/80/1c/6c/ea/0900823d801c6cea/repairInfoPages.htm Scroll down and click on Fig. 24. Click on the little white box in the upper right hand corner of that figure to enlarge it. The image can be downloaded and printed.
  • edited April 2008
    The problem is probably with the O2 sensor itself. Because the code indicates a problem with the heater circuit of the O2 sensor. The most common failure of O2 sensors is with the heaters. The heater in the sensor becomes damaged from thermal shock.

    The sensor after the cat is probably the same as the one before the cat.

    Tester
  • edited April 2008
    Tester is correct, it probably is a defective oxygen sensor. It only costs the price of a new oxygen sensor to find out.

    Just speaking for frugal me (you can use other terms, if you wish), I would use a digital multimeter ($25 at Walmart) to measure the electrical resistance (ohms) of the oxygen sensor. To do this, I would disconnect the electrical connector from the oxygen sensor, and measure the ohms between the terminals for the yellow/red wire and the black wire terminal on the O2 sensor. It should be low ohms. Compare to the voltage on the yellow/red wire of the other O2 sensor.

    I would also like to know if power (12 volts) is coming in on the yellow/red wire. I would turn the ignition key to RUN, and touch the red probe to the end of the yellow/red wire, and the black probe of the multimeter to a good, clean, metal surface on the engine or transmission.
    Again, compare the voltage measured (12 volts) to the other O2 sensor.
  • edited April 2008
    [WOW! A new glitch to enjoy on this site! I "edited" and "changed" the last line of my previous post. The changed text WILL NOT show on my post!]. The last line should read:
    Compare the voltage measured (12 volts expected), on the rear O2 sensor yellow/red wire, to the voltage (12 volts, expected, again) on the yellow/red wire going to the front O2 sensor. They should be the same 12 volts.
This discussion has been closed.