Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Dodge 5.2 magnum V8 misfire

This is a 1999 Dodge 5.2 V8 in a Ram Van 1500 and it has always preferred to run on 5, 6 or 7 cylinders, never 8.

All the Chrysler TSBs for misfire were performed, the engine has new heads, burns no oil and has 150k and good compression all around..

Injectors removed, cleaned and tested, all new Autolite Platinum plugs, all new wires, new Bosch Oxygen sensors.

First success to get to 6 cylinders fireing was a new Crankshaft Position Sensor.

Next was to clean and re furbish the PCM module connector contacts and this got things to a reliable 7 cylinders.



I am out of ideas. Help!
«1

Comments

  • edited September 2007
    Do you have access to try another PCM? If so switch it out to see if it resolves your problem. Do you know which cylinder is not firing? If you do then check the fuel injector pulse at the fuel injector to see if it is firing correctly.

    I'm not familar with your system to know if your injectors are controlled by the ECM or some other system
  • edited September 2007
    Sorry I do not have a spare PCM. This car's PCM directly powers the injectors. The injector leads usually show a pulse but occasionally miss one. I Have not been able to identify a particular cylinder causing the steady miss. All exhaust ports are hot and all plugs and injectors have pulsed voltage.
    The misfire most pronoumced just off idle as a single cylinder missing. Also at light throttle in high gear climbing a slight grade it will give a random lean miss after about 20 seconds of load. Sort of like running out of gas.
  • edited September 2007
    What do you mean it "always" has prefered to run on fewer than 8-cylinders? It's done this since it was new? I'm assuming that there was some time in the truck's life that it ran fine. What makes you think that it's only running on a few cylinders as opposed to all of them poorly?

    Cars nowadays can't just drop cylinders here and there like old ones could-- there would be catastrophic consequences to driving it around for any length of time with a whole cylinder consistently missing. Is the "cylinder" perhaps just your unit of measure for how well the truck is running?
  • edited September 2007
    Do you have any CEL? If so pull the codes and post them here.
  • edited September 2007
    Can you go to a salvage yard and see if they will let you try an ECM?

    Have you checked your TPS or your temp sensor? They can cause the stumbling you are talking about.
  • edited September 2007
    A number of dealers and shops have performed code checks to no avail. I have examined all sensors I can using VOM and a scope but the Crankshaft Position Sensor was the only weak item. The flex plate on most Dodge V8s have about .010" of runout and the weak original CPS was missing some windows so two or three cylinders would get no fuel and no spark. Chrysler finally redesigned the sensor recently and the new model, which is solid plastic on the working nose, will detect a window from as far as 0.150 inches away. This made a huge improvement in power, mileage and smoothness.

    On a recent long trip gas mileage was down in the 14s and I had a long way to go so pulled all the PCM connectors and rebent all the socket's spring contacts to give better grip. Mileage jumped to 17.5 and car ran smoother, started on the first cylinder and had better power. Still a weak cylinder there somewhere and the lean misfire under light load.
  • edited September 2007
    This van was a Chrysler program car for the first several years of its life and only entered private service in 2004 with 42.000 miles. I think the corporation used it as a taxi at one of their facilities. Its an eight passenger short wheelbase.

    The first private owner drove it 72,000 miles in four months and I then acquired it from a new car dealer. It seemed to run well but 50 miles from the dealer's lot the intake manifold plenum plate gasket failed and it started to suck oil out of the engine with spectacular smoke clouds. Being familiar with Magnum engine problems we babied it home with lots of oil and began working on the engine problems.

    The van drives very nicely now with seven strong cylinders and the mileage is actually very good but it still has this nagging weak cylinder and part throtle misfire.
  • edited September 2007
    I think you should drop by a local AutoZone and get them to read the codes. Sometimes an uninformed opinion can be the best option. Post any results back here. AZ, or other parts houses, will do this free.

    Also, define "good" compression. People have posted on here with "good" compression readings of 130, 125, etc. and in one case, even claimed that their readings of 90 to 100 PSI were good. Every one of those readings is junk or borderline junk.
    Do you have a cylinder by cylinder listing?

    Since I'm a big fan of vacuum gauge use, I would connect one of those to the intake and see what's going on. A vac. gauge can tell so much about what's going on inside.
  • edited September 2007
    Why isn't the crankshaft position sensor (cps) reporting the misfires unless it's the CAUSE of the misfires?! Backprobe the cps, set the multimeter on Hz. The Hertz, at idle, should be: See: Typical Diagnostic Reference Values at alldata.com. I think the value would be around 500 Hz, and steady. If the cps output isn't steady, why isn't?
  • edited September 2007
    Thanks, I will try this out and see how the CPS is doing. From past testing with a scope I know a missing CPS pulse will not light the CEL.

    On the compression testing the lowest cylinder is 145 and the highest 165. When the heads were pulled virtually every cylinder had a cracked seat land between the valves and the shop installed hard inserts to repair.
This discussion has been closed.