Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Oil light comes on when I come to a stop

Oil light comes on when I stop and goes off once I move again. Oil is full and just changed. What causes this & can I repair? I have a 01 Chy Sebring withh 100K miles on it. I bought new & have changed the oil every 3K miles since I have had it.
Tagged:

Comments

  • It's probably a bad oil pressure sending unit. Before you replace it make sure the wire is still attached and not broken/damaged.
  • This sounds like you have a bearing clearance that is excessive enough to cause the oil pressure at low engine rpms (when the oil pump's output is lowest) to fall below the oil sending unit pressure threshold for when the light turns on. That threshold is often in the 7 psi range.

    I would try missleman's suggestion for a new sending unit first.

    If it were my car and a new sending unit didn't solve it, I'd put an oil pressure gauge on it to get an accurate reading for what the pressure really is. If it is only low at idle but rises to "safe" ranges at higher rpms, then I'd live with it, perhaps with a slightly thicker oil. Many engines have had long lives like this.
  • Does it have the 2.7 motor? 99-02 Chrysler 2.7 motors had major oil sludge issues. They run hot, have poor oil recirc designs and basically wear out due to poor oil flow.
  • edited December 2012
    RE: 99-02 Chrysler 2.7 motors had major oil sludge issues.

    I thought the workaround for avoiding sludge in these "sludge-prone" engines was to change the oil more frequently. The OP says the oil was changed every 3K miles since it was new.

    I haven't followed every sludge-prone engine, but 3K oil changes is well within the intervals to overcome sludge for many of those problematic engines.
  • FIRST, replace the sending unit..Then have the actual oil pressure checked with a direct reading gauge at various RPM levels...If the oil pressure turns out to be on the low side overall, you can drop the oil pan, clean the oil pump pick-up screen and replace the pump...If the engine is sound, this should cure the problem for a reasonable amount of money....
  • If this just started right after the last oil change, then the first thing to do is replace the oil filter. You may have a defective oil filter and you are starving your engine. Do this immediately. If that doesn't solve the problem, then try the oil pressure sending unit or get a real oil pressure test with a mechanical oil pressure gauge.
  • I've read that this is a common issue with this engine. Folks have passed some solid device here already. I would check the level, validate that the correct type was installed during the last oil change and swap out the oil filter. Check out the Sebring forums on this issue as it has been reported by many. From what I have taken from folks as a common issue is the sending unit itself due to location and heat, it goes bad and starts sending false indications.
This discussion has been closed.