Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

WHILE DRIVING, ENGINE SUDDENLY STALLS

Recently, after exiting the freeway, may car ( lexus 1995 SC400) suddenly stalls. After a moment of panic, i placed the emergency blinkers on,. coasted to a stop, and re started the engine. It started right away and I continued driving home. The engine sounded perfectly fine, no hesitation, no roughness. After a few days it happened again....again after exiting the freeway and slowing down for city traffic. The Garage that serviced my car for many years has checked the electrical system, replaced the spark plug wire set, cleaned " throttle body". These seemed to fix the problem. The car was fine for 6 months and then it happened again last week. Need help quickly as this is making driving a stressful and fretful experience.
Tagged:

Comments


  • The first thing that I would check for is a defective ignition switch.
    On a 17 year old car, it is very possible--even likely--that the ignition switch is simply worn out.
  • edited November 2012
    The next time you feel the engine is about to stall, brake with your left foot and then slightly tip into accelerator. If this prevents the engine from stalling the problem is with the Idle Air Control valve.

    The IAC valve is mounted on the throttle body and this component allows the engine to idle anytime the accelerator is released. Sometimes the IAC valve accumulates gum and varnish inside it where it sticks and the engine stalls. It could be that when the throttle body was cleaned some of the gum and varnish was removed from the IAC valve and this remedied the problem for 6 months. Next time have the IAC valve removed from the throttle body so it can be thoroughly cleaned along with the idle air bleed port on the throttle body.

    Tester
  • Thanks for the tip. I can not follow your suggested confirmation test because the engine does not show any signs of stalling. It does not sputter and the engine does not shudder. The engine just quits. One moment it is running smoothly, the next moment it is dead. But when I start it it starts right away, without any hesitations. This does not happen when the engine is idling ( e.i. at full stop) but while at slow speed after transitioning from freeway driving. I do not know much about cars but it seems that something momentarily disrupts the electrical system.
  • If it seems like someone reached over and turned the ignition off, then look at something like a faulty crank sensor, or ignition module.

    Tester
  • Has anyone recently hooked up a scanner and checked for fault codes? Just because the check engine light isn't lit doesn't mean there aren't any codes stored.
  • To go along with what Tester mentioned, it's still possible the problem could be related to the Idle Air Valve because on an exit during this transition you refer to the accelerator pedal is released and even though the car is coasting the throttle plate may close and the Idle Air Valve may be acting up enough to cause the engine to die.

    The plug wire set would not be behind this problem and cleaning may or may not fix an Idle valve problem. Much could depend on how the the throttle body was previously cleaned. If someone removed an intake boot and simply shot half a can of aerosol cleaner into the throttle bore that may not be good enough.
  • Could be a bad MAF? They like to fail and stall motor.
  • Thank you to Tester and everyone who sent in valuable tips on what to look for. The car has been working just fine so far but I will take your suggestions and have the car checked thoroughly
This discussion has been closed.