Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Corolla rough idle

My exhaust system was replaced on my 2005 Corolla in August. After driving it for just a few days, there was a shaking when the car idled. The mechanic replaced two engine mounts and the idle was much worse! He said it was ok to drive, so I started on my planned trip across the country. In Denver I took it to a mechanic at the Toyota dealer and they adjusted the throttle. It was better for a while, maybe a week and 1,000 miles. Now it is worse than ever! Having gotten two totally different causes from mechanics, I am not sure what to do next.

Also just before the exhaust sytem went, I had the 60,000 mile service done and had the car totally checked out by both Toyota, and an independent mechanic who specilizes in Japanese cars. After a car wash in California, the maintence required light came on.

What is going on?

Comments

  • If it's a check engine light, and not the oil change reminder light, then get the code read, and post the actual code. Most local parts places can do this for you. Most will do it for free in hopes they can sell you parts. We can start after we get the code. Most of the guys here are smarter than me at deciphering thse codes, but I'm learning...and I have a few tricks of my own. :)
  • Oboy. I don't know where to begin.

    First, why was the exhaust system replaced? What part(s) was(were) changed? Do you know if they replaced the oxygen sensor when the did the exhaust?

    The engine shaking was a cylinder not firing. The mechanic never fixed the problem. And, since the engine was shaking when you picked it up after the exhaust change, it makes me wonder if he used a "generic" exhaust system and eliminated/broke/did-not-check the operation of the upstream oxygen sensor, which if it's bad can make the engine shake. Changing the mounts was simply bogus.

    I thinkcommunicating the problemto us may be compounded by your having misunderstood the dealership in Denver. A 2005 has an Idle Air Controller to control the throtte, operated by the ECU based on its input signals. One cannot "adjust the throttle" as in he days of old.

    You didn't say why the exhaust system was replaced or how much was replaced. But of the engine was running well before that work was done, I'd highly suspect the upstream oxygen sensor. If the exhaust was changed to solve an operating problem, we'll need to know what that is before making any guesses.

    One thing I can tell you for sure.....you need a new shop.
  • While I was stopped at a light, suddenly I heard a terrible noise, like a muffler was gone. I thought, "boy, someone needs to fix their car." When all the cars drove off, and I was the only one there, and the noise was still there, I realized it was my car that was making the noise! The mechanic claimed he couldn't find the parts needed and they had to be manufactured in California and sent to Ohio, which took several days. He replaced the whole exhaust system as a part had rusted through. The receipt from Denver said, " Found dirty throttle body, restricting air flow. Cleaned throttle body."
    5:05PM Comment Write a comment
    tomgreen → the same mountainbikewell the rarends on these have clutches in there forthe posi trac and
  • The receipt from the exhaust work says,

    Exhaust pipe is broken at flange.
    the parts replaced were -
    1 front exhaust pipe/converter WP TOY3248
    1 gasket NA-31379
    2 exhaust spring WP-35133
    2 exhaust bolt NA-35138
    1 gasket NA-31378
    2 exhaust spring NA-35133

    The parts for the motor mount work were
    1 motor mount WP-12305-0D023
    1 motor mount WP-12361-0D100
  • edited October 2011
    OK...not to be too difficult...but, like I said...

    "get the code read, and post the actual code. Most local parts places can do this for you. Most will do it for free in hopes they can sell you parts."

    A "MAINT RQD" comment doesn't help anyone. It only means the computer sees something wrong.
  • The maintenance required light is the oil change due indicator. It comes on every 5000 miles. Not the same as the check engine light.
  • Okay, it sounds like the exhaust system rotted out and needed replacing. As I suspected, he never changed the oxygen sensor. I'm wondering of he checked it.

    The "maintenance required" light may be the one that tells you it's time for the periodic maintenance. Look in your owners' manual to see if that's the light you're seeing. The Check Engine light is a different one, and that's the one that indicates a problem. But, again, check your owner's manual I can't tell for sure which one is lite from here.

    I gave your problem a bit more thought and realized that ither possible causes exist than what I suggested that could cause severe shaking at idle, including transmission problems. But The engine mounts were clearly not the cause of the problem, the problem clearly hasn't been properly diagnosed yet, and you clearly need a better shop.
This discussion has been closed.