Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Buick LeSabre fuel gage has gone whacko

I have an '04 LeSabre custom. The gas gage is housed in the instrument cluster along with the speedometer and a separate temp gage. The fuel gage is at o'clock TOP of about a 4" circle by itself. Empty is at 10:00 o'clock and full is at about 2:00 o'clock. For the last three FILLups, the pointer has gone way past full to point anywhere from 6:00 to 9:00 o'clock. When it gets low, it does seem to indicate near-empty as it should. I can live with it by setting the trip odo have access meter to zero, and filling at the. 400 mile mark, but the wife is bugged.

Is the problem in the gage as I suspect?

I have access to a complete cluster from a similar car, but it's a Limited with a tach and extra buttons for fuel economy and actual gage readings like temp and oil pressure. Can this cluster be directly plugged into my lower priced car? Is the total mileage displayed held within the cluster, or in the car's "brain "? I really don't want to disclose MORE miles than the car really has, 127k versus 167k on the used cluster.

Thanks for your input.
Tagged:

Comments

  • These Vehicles Do Have Some History With Fuel Level Sensor Problems (In-Tank Sending Unit On Fuel Pump Module).
    Sulfur in the gasoline reacts with and erodes the "wiper" (tiny wires) on the sensor arm.

    This does cause the gauge to go whacko, but I've not heard of one going whacko with the indicator needle going outside of the normal range that one ordinarily sees. I usually goes whacko between full and empty.

    The fuel pump module / fuel level sensor should be accessible on the trunk floor just ahead of the spare tire well to the right a bit. A small oval panel with a half dozen screws covers the access hole. I'm wondering if there's a way to unpug the harness there and check electrically, somehow.

    One need not replace the whole fuel pump module (but, it must come out) as some will tell you. It's possible to replace just the level sensor (sender) or even just transfer the wiper piece from one.

    Sorry I can't help more. Maybe some of the more electrically inclined can tell how to test this baby.
    CSA
  • edited September 2011
    If you can get to the wiring behind the instrument panel, you can check the voltage (or resistance, I'm not sure which) on the wire from the fuel sending unit. You will need the manual to know the exact reading. If the reading when full is correct, then the problem is the gauge. If the reading is too high or too low, then the problem is the sending unit.

    Google also shows a list of problems with GM fuel sensors of your vintage, with some extended warranties and repair programs. But "new GM" might have dumped them. It won't hurt to ask at your dealer for service bulletins and any repair programs.
  • Most fuel gauge problems are caused by a problem with the wiring to the sender or the sender itself, not the gauge. You should be able to verify the problem by removing the wire from the gauge at the sender connection and tie a variable resistance to it. By changing the resistance the gauge should move accordingly.
This discussion has been closed.