Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Check Engine: Lean Air/Fuel Ratio

After my 2005 Nissan Sentra check engine light came on I had the codes read. The code is indicating that there is a lean air/fuel ratio mixture. I'm thinking this may be a false positive(bad sensor), clogged fuel injector, etc. The light has gone off and come back on. I live in Utah where the cold weather may play a factor. Can anyone help me diagnose the real problem, or where I should start?

Comments

  • edited March 2011
    I would start by removing the Mass Air Flow sensor and clean it with an aerosol MAF sensor cleaner.

    If the MAF sensor has dirt/debris on it, it doesn't detect the actual amount of mass air entering the engine. The computer then compares this reading to the signal from the O2 sensor. If the O2 sensor detects more air in the exhaust than what the MAF sensor signal is sending to the computer, the Check Engine light comes on with this code indicating a lean fuel condition.

    Tester
  • edited March 2011
    People get this wrong a lot so I am going to ask for the code. If the fuel trim is moving to values that lean out the mixture then you have a system that is trying to deal with an inital rich condition,it is a bit backwards I know,
    You probably did not see fuel trim numbers just a code,what was it?

    In anycase cleaning the MAF is where to start.
  • edited April 2011
    That CEL (check engine light) is just a kid in class waving her hand trying to get you attention because she has the answer. You need to have the codes read. Some places will read them for FREE. Try Autozone or Advanced Auto Parts. Get the exact code (like P0123) not just their translation into English and post it back here.
  • edited April 2011
    The part that actually generated the fault code is the front oxygen sensor. After you clean the MAF, that's the first part to replace..
  • Thanks for all of your comments. Per your advice I cleaned the MAF with some MAF cleaner. I unplugged the battery for a half hour to allow the codes to reset. However after several days the light is back on and the code is P1273. Having cleaned the MAF what should my next step be? Should I just let a professional take it from here?
  • The next thing you'd do is check for intake leaks - starting at the MAF and then onto everything on the manifold including the intake manifold itself. I usually start with a careful visual inspection and then move on to an unlit propane torch feeding around all possible leak points. One thing to inspect very carefully is the intake snorkel itself. Cracks & splits can be very hard to see - twist, pull, bend, etc.

    There is a TSB out for this code (NTB06-039a) but it specifies it is for Altimas. It may be worth a call to a dealer service dept though just to find out for sure.
  • edited May 2011
    I don't know about Nissan, but our ford had nearly the same episode. I tried cleaning the maf sensor, and then given the myriad of other possibilities I took it to the dealer. They claim that they can read more codes than the auto parts stores, replaced plenum seal and some o rings and all has been good. It may be worth your while to have a dealer look at it as of all the possible fixes plenum seal and o rings never came up.
  • if you aren't losing coolant as in a blown head gasket which will ruin an O2, and don't have an exhaust leak then the oxygen sensor is the most likely culprit.
This discussion has been closed.