Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Head lights flickering

My head lights on my 2006 Dode Charger SXT have been flickering, it is intermittant and not really sure what could be the cause. I have checked the wiring and fuses. I thought it might be the ECU but the other night I heard the A/C kick on and the lights flickered at the same time. I also notice the lights dim for a split second when you get on the brakes (ever so slightly but they do dim) Could it be the ECU or could it be the alternator or something else like a voltage regulator (if this was an older car I would have figured it out already....

Comments

  • edited November 2010
    Most likely it is a poor connection somewhere between the battery and the light. That path includes the ground wire from the battery to the frame and body of the car, to the dashboard and the positive wires from the battery to the fuses, circuit breakers, switch etc. all the way to the lamps, which also could be the problem. In addition it could be a bad charging system.

    Kind of hard to tell from here. However keep watching this thread. There may be a Dodge Charger specific problem that could be an easy DIY fix. I certainly don't know all the possibilities, but there are lots of people here that know a lot more than I do.
  • edited November 2010
    Original battery? Have it tested.

    Most auto parts stores will test the battery and the charging system free.
  • edited November 2010
    The flickering lights might from a failing rectifier in the alternator. The rectifiers convert AC voltage to DC voltage. When a rectifier fails, it allows an AC ripple voltage into the vehicles electrical system causing the lights to flicker. When having the battery/charging system tested, have them measure for AC voltage at the battery. If any amount of AC voltage is measured at the battery it indicates a failed rectifier in the alternator

    Tester
  • edited November 2010
    Yep. The first thing to check is the battery wires. Sometimes the clamps work loose from vibration and then start making poor contact. Your description is a classic symptom of a loose wire.
  • edited November 2010
    Tester, Thank you for the info....I will have my mechanic take a look at it. He has been stumped so far. As far as the other replies I thank you but after 15 years of being an aircraft avionics technician I have a few doubts.....bad battery or charging system or loose connections? Sounds legit until you look at other factors, I have personally cleaned grounds and other electrical connections, I have cleaned and reseated the entire fuse block under the hood and in the trunk, I have tightened connections with no joy. The problem effcts both headlights at the same time, it isn't vibration related or heat related. Leads me to believe it is a component such as a ballast, a rectifier, or a control unit, not a loose connection or a battery. Even though the battery is a component, it would effect more than my headlights such as starting and other electrical systems, The only lights that are effected are my headlights. I have figured that it has to be a voltage related problem that would make the ECU sense the inproper levels turning the headlights off until it senses the proper levels. I failing rectiufier sounds like such a problem that would cause this condition. The battery may have a small chance but the lack of other problems leads me to thinki otherwise. Thanks
  • edited November 2010
    Its often amazing how much information comes out of the woodwork after some suggestions are made. Much of the time I just wonder why people hold out and then only clarify later.

    You did say "I have checked the wiring and fuses" - but to a lot of people that means they opened the hood and looked at them.

    I'm not picking at you (ok, maybe a little) - I'm just wondering about that logic. Why not include all of the above info in your initial post and save others the time of having to go through the simple things? (Its kind of like telling someone your computer won't boot up but failing to mention that you did already check to make sure its plugged in).

    I'm just bringing it up in general - it happens all of the time. Someone says their car is idling roughly and when the first suggestions are things like spark plugs and fuel filters they sometimes come back (with just a hint of attitude about their own competence) with a huge list of things they've already done...then you're just left to wonder why they didn't say so in the first place.
  • edited December 2010
    cigroller, thanks for the help with fixing my car...oh wait...you were too busy running of at the keyboard to be of much help. if I had an engine related problem and I said I checked for spark and compression would you need to know all the steps I took to do this? The reason my headlights were flickering was due to the computer holding a stray voltage in the memory and during certain situations that stray voltage would effect the controller for the headlights. The computer needed to be wiped clean and reflashed with a new program that eliminated the stray voltage. Problem fixed. No loose wire, no battery connection, no dirty ground, no faulty battery. (which would have been found when I said I checked the wiring and connections and the fact that if it was an older car I would have found the problem....no computer to mess things up) The suggestion about the alternator was a good point since I had not already done that and it was checked and came back with no discreps noted. It was along the same lines as the real problem of a incorrect voltage the effected electronics. The problom was solved by a guy on LX forums who had a simular problem and a TSB corrected his problem and it worked for me as well.
  • edited December 2010
    I think Tester is correct about the alternator. Bad diodes inside it cause this kind of trouble. To verify that, using a DVM check the AC voltage across the battery while the engine is running. If the voltage is more than .1 volt there are bad diodes inside the alternator causing excessive ripple voltage.
This discussion has been closed.