Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

BMW 3-series mysteriously loses power on freeway

This problem has stumped three sets of mechanics, so I thought I'd try the real experts.



We have a 2002 BMW 3-series station wagon, with an automatic transmission. Up until a month ago, we hadn't had any big problems with it, and we've done all the recommended maintenance. Then we decided to take a trip from our home in coastal Los Angeles to visit my mom in Arizona.



After two hours of highway speed (75-85 mph) driving, we were out in the desert. I looked at the gas gage, and it was about halfway between "Empty" and "1/4 tank", so I planned to stop at the next gas station. As I drove along, the car unexpectedly lost accelleration. It did not respond to pressure on the gas peddle. For the next minute or so, it seemed to lurch between idling for a moment, accellerating for a second or two, and idling again for a few minutes. Each time it did so, the tachometer popped back up, then down again. I maneuvered the car to the side of the freeway, where it stalled after a few minutes.



It was a hot summer day, and the exterior air temperature was about 104 degrees. However, the engine had not overheated. I could restart the car, but it stalled again after a few seconds.



We called for a tow, and about half an hour later a flatbed truck arrived. The driver tried to start my car, but had the same problem -- it would start, but stalll after a minute or so. So he winched the car up and headed to a mechanic.



When he unloaded the car about 30 minutes later (i.e., about an hour after it failed), the mechanics were able to start it and drive it without problem. They checked the computer and found that it had not recorded any faults. They looked the car over, and drove it around for a while, but couldn't find any problem. After two hours, they declared themselves stumped. Their best guess was that an intermittently faulty crank-shaft sensor had turned off the engine. We then refilled the gas tank, and drove back home without incident.



Four days later, we took it in to a local indie BMW repair show. They rechecked the computer and also found no recorded faults. After four or five hours, the mechanic called and said he had "eliminated all the other possibilities" and we needed $800 worth of repair to the throttle (plus another $600 worth of recommended work replacing oxygen sensors and the like). Not knowing what else to do, we had him do the work.



After that, we drove the car on short trips (no more than 45 minutes or so) for a while without any problem.



Three weeks later, I went on another trip out to the desert. It took a bit less than 4 hours of freeway-speed driving to get there, and it was another 100 degree day, but we had no problems on the way. However, on the way back at 3:00 a.m., after about two hours of driving, we had exactly the same problem. The car suddenly lost power, stuttered/lurched for a minute or two, then ultimately stalled. Once again, the fuel gauge showed about 1/8th of a tank of gas (the "low gas" light had not yet come on). Once again, the car had not overheated, and would start, but stall out after a few seconds.



This time, I waited about half an hour, but the car still wouldn't drive, so I called a tow truck. It was a flat-bed truck again, and as before, after we arrived and the car was lowered back down, it started and drove normally. I refilled the gas tank, and drove home without incident.



The next day, my wife took it over to the mechanic that had "repaired" it. He said it must be something else that had caused the problem this time (uh huh...), maybe the fuel pump. His diagnostic computer was down, so he had her take it to another nearby show, check the recorder, and promised to call us as soon as he looked over the results. Of course, we never heard from him again. Once again, the computer showed no faults.



So, on to independent mechanic #3, another BMW specialist. Computer check: no faults. He hooked up a fuel pressure gauge and tried driving the car around, but didn't notice anything unusual. He left the car running for much of yesterday afternoon, but nothing unusual has happened. These tests have been done with a nearly full gas tank (my wife unthinkingly filled the gas tank before taking the car in). Mechanic #3 hasn't siphoned the tank down, but doesn't think the level in the gas tank was responsible for the problem. So far, we are getting nowhere.



We have been planning to leave in a couple days on a driving vacation to Utah, but I don't want to find myself out in the middle of nowhere with a dead car. Any idea on what the problem is, and how I can get it fixed. Thank you.

Comments

  • edited September 2010
    I'd bet on the fuel pump. When they're starting to fail, they can start acting up when they're hot. A long drive on a hot day with a low fuel level is exactly a recipe for that (as the fuel helps to cool the fuel pump).
  • edited September 2010
    Your car has two fuel tanks. The fuel pump takes fuel from the one on the passenger side. There is a transfer pump that moves fuel from the driver side tank to the passenger side tank. The fuel guage averages the readings from the two tanks to tell you how much fuel you have.

    If you run out of fuel with around 1/4 tank showing on the guage, it means that the passenger side tank is empty, and the driver side tank is less than half full; too low to gravity feed over to the passenger side tank. The transfer pump is not working.

    I am not certain, but I think that the transfer pump in this car is a jet pump. That means that there are no moving parts. If it is not working, that either means that the fuel filter is nearly plugged and there is not enough fuel circulating to make the jet pump work, or rubber seal has failed in the jet pump so it is leaking too much to work.

    If you have never replaced the fuel filter, you might be very lucky and find that a new fuel filter solves your problem. I would not bet on it, though.

    The bad news is that the main fuel pump has run dry several times. That is really hard on it. It may last another 100k miles, but it probably won't. If you want the car to be as reliable as possible, you probably want to replace that fuel pump when you fix the transfer pump. On-line price for a new main fuel pump is $150. Changing it is not difficult, but it is dangerous to open a gas tank if you don't know all the safety precautions to take, so it is best to pay a professional to do it.

    Speaking of professionals - it seems like you are taking your car to people who only know how to read computer codes. If there is no code stored, they are out of ideas. See if you can find a good, honest, German car specialist shop. Here in Sacramento we are very fortunate to have several excellent shops to choose from.
This discussion has been closed.