Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

HYUNDAI SONATA INTERMITTENT NO START

My daughter's 2005 Hyundai Sonata continues to strand her periodically (12 times in the past 18 months). Sometimes weather seems to affect it - warm/hot not good. It will not start after being driven until warm/hot (esp. with air cond. going) and left to sit for a relatively short amount of time. Lights and bells sound, but absolutely no action from engine. If left to sit a couple of hours, it starts as if nothing had happened. Hyundai isn't cooperative, as it never acts up when in shop. The problem started while still under warranty, but it is now over 6K and warranty is off. Anyone out there ever have similar problem? Any advice?
Tagged:

Comments

  • edited December 2009
    This must surely be a wide-spread problem.
    There are currently 5 posts on the exact same situation!
  • edited December 2009
    First off, you don't need to post the same post 5 times.

    As far as the problem, it sounds like it is definitely in the starter circuit. Does this car have an alarm system, and is it factory or aftermarket? The things to look for are the relays, starter motor itself, and ignition switch. An alarm system complicates things, because they typically add another relay to prevent the starter from being used if the alarm goes off.

    Also does it have a remote starter function, and is it aftermarket or factory? There have been many posts about ad-on remote starters preventing the car from starting.
  • edited December 2009
    Thanks for your response. I had no idea the problem would post 5 times - I'm new to this forum, but I thought I was posting only once. Have a little compassion...

    Yes to the following: factory alarm.
    No to remote starter

    Do you have any insight re: the temperature connection? Hot and muggy or just damp and warmish (got caught last weekend in central Mass. - 40 degrees and moist) and/or the fact that just letting it sit has so far ALWAYS solved the problem?

    Again, pardon my posting blunder and thank you for responding.
  • edited December 2009
    Sorry - I guess I inadvertently posted more than once. Have patience with a new forum member.
  • edited December 2009
    I too had a problem with the site once recently and ended up with multiple postings. What I discovered was that if the web lackys are doing anything with the site it'll freeze the attempt at posting, causing a repeated attempt, and then when they're done multiple posts will occur.


    Now, to the question: Hyundae just does not want to bother. Technically, since it was reported while still under warranty, they're obligated to fix it under warranty.

    But if it were my daughter I'd take it straight to a reputable independantly owned and operated shop. The heck with Hyundae, there's a daughter-safety issue at stake.

    This problem is diagnosable. This should have stored fault codes in the ECU. These can be read by the willing. Beyond that, various ignition components that commonly cause these symptoms can be tested for susceptability to heat failure.
  • edited December 2009
    Thanks so much for the info. re: the multiple posts and the car problem. We will continue to seek an answer!
This discussion has been closed.