Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Does battery affect how engine runs

I drive a 1999 Sable. Last night I replaced the original battery and took the car for a good drive to make sure the new one was charged. The car seemed to run a lot more smoothly and maybe even more quietly. Was that psychosomatic or does the battery really affect how an engine runs? Thanks
«1

Comments

  • edited November 2008
    Was the old battery dead? Did you check to make sure the alternator is working fine? If the charging system doesn't supply enough electricity, the car will stumble and die. I'd get the alternator checked at a parts place (they'll do it for free) just to make sure you aren't about to have problems with your new battery from under charging.
  • edited November 2008
    When you disconnected the old battery you probably reset the engine computer. That could change the way the engine performs.
  • edited November 2008
  • edited November 2008
    Have the charging system checked IN the vehicle as there may be something other than the alternator possibly at fault. Commonly referred to as a 'load test'.

    Winter's here already, so unless you want to mess around in the freezing cold one day, I'd recommend you make sure all the cable connections are clean and are on wrench tight.

    This means at the STARTER end too. Add some dielectric grease after to keep moisture out.
  • edited November 2008
    I have seen a bad battery affect how a car runs, especially on smaller cars.

    With my old Civic, I had a battery die. I tried jump starting the car, but as soon as I took the jumper cables off, it died. I did it again and gave it some time to charge before I unhooked the jumper cables. This time it ran but it didn't run very well. After I installed the battery, it ran fine.

    If your original battery lasted nine years, I would stick with the same brand.
  • edited November 2008
    When the battery (~1 year old) on my 2000 Blazer was run down to 12.1 Volts (~25% charged) it started having driveability problems. The idle was ~150 rpm higher and the torque converter lockup was not engaging. When the battery was fully charged (12.6 Volts) the truck ran fine. My guess is that the VCM (computer) needs a minimum input voltage or it gets a little flakely.

    Ed B.
  • edited November 2008
    My guess is that the VCM (computer) needs a minimum input voltage or it gets a little flakely.
    Computers don't work that way....If the battery was making it run poorly..it might be a Sensor that was sensitive to the low voltage.
  • edited November 2008
    Thanks, I never thought of it that way.

    Ed B.
  • edited November 2008
    A poor battery or dirty battery cables can absolutely cause a car to run poorly, sometimes in very odd ways. Some cars are much more sensitive than others.

    Auto computers collect most of their information based on resistance readings. They read resistance by sending a low voltage signal to the sensor, and counting how long it takes for the signal to charge a capacitor in the computer up to some threshold voltage. If the supply voltage is doing odd things as the computer is scanning its inputs, the inputs appear to be changing in irratic ways, and how the computer will respond is anyones guess.

    Since transmissions started to be computer controlled, more than one transmission problem has been solved by battery replacement.
  • edited November 2008
    I agree with Manolito completely that a weak battery or cable end can cause poor engine performance. It's amazing that your battery lasted this long; most go belly-up in about 5 years.

    When I owned my old Sable I could always detect when the cable ends needed cleaning because when the current draw was high (lighting, A/C, etc. and especially at idle) the engine would develop a subtle stumble and sometimes stumble at speed.
    I chalked this up to poor conections and a high current draw dropping the voltage down too much. When the voltage drops everything in the system is going to be affected.

    Every single time when the cable ends were loosened a faint scale was present on the mating surfaces and when cleaned with a terminal cleaner the stumble would go away.
This discussion has been closed.